Subject: ICQ

From: [email-masked]
Date: Tue, 4 Jan 2000 13:34:39 +0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi,

Did anybody know how to setup ICQ gateway
in FWTK toolkit?

Thanks

Vincent Huang

---

From: Mariusz Potocki <[email-masked]>
Date: Tue, 04 Jan 2000 08:53:14 +0100 (CET)

> Did anybody know how to setup ICQ gateway
Use UDPrelay

--
Mariusz Potocki

Microsoft: Where do you want to go today?
Linux: Where do you want to go tomorrow?
FreeBSD: Are you guys coming or what?

---

From: "Jonathan B. Smith" <[email-masked]>
Date: Tue, 4 Jan 2000 08:52:36 -0800

I've tried two methods, the one that works fully is by using socks.
The other was to use udprelay to the main icq server. This didn't fully work
because for some aspects of ICQ you need a direct tcp/ip connection to the
other users.  In other words, go with SOCKS.

---

From: [email-masked]
Date: Wed, 5 Jan 2000 17:45:18 +0300

-----BEGIN PGP SIGNED MESSAGE-----

nuqneH,

> other users.  In other words, go with SOCKS.

No. You don't _need_ direct tcp connection. ICQ will try it, though.
In other words DON'T use socks if you don't understand well how it works
and things you should control. It will probably break your security policy.

UDPrealy is way to go. (i'd say better don't use ICQ at all, but ..)

                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!

---

From: "Carsten Witt" <[email-masked]>
Date: Wed, 5 Jan 2000 19:23:24 +0100

Hi ,

can you say me how i do a udprelay !???

I don't how it works !

Carsten

.
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, January 05, 2000 3:45 PM
Subject: Re: ICQ

> -----BEGIN PGP SIGNATURE-----
> Version: 2.6.3i
> Charset: noconv
>
> iQCVAwUBOHNY/KH/mIJW9LeBAQF+8gP/f4vxYUGSa/qZqTT5QTukBTpUOInseG5U
> dhTVUV9wpYajVedImSvdCmqFY97n7ti0Uc8Dv268aWjFEQYAEvyivqMHAftXl5YE
> ARETTosMI4x3gr5QaYz428q4y3QZ1yZpkn3ftub37Q6qU7SdSZoPrd6v+zQEycwO
> kwEhz6pjmVU=
> =C2+D
> -----END PGP SIGNATURE-----
>
>

---

From: "Jonathan B. Smith" <[email-masked]>
Date: Wed, 5 Jan 2000 13:37:37 -0800

ICQ does require tcp/ip connection to other users for icq chat and file
requests. If you're only using udp then you will not be able to use these
functions.

---

From: [email-masked]
Date: Wed, 5 Jan 2000 21:46:54 +0300

-----BEGIN PGP SIGNED MESSAGE-----

nuqneH,

These functions are unsafe, cannot be controlled properly with socks and
should be disabled anyways. If you don't understand that, i don't think
you need fwtk, socks-based firewall-like system should be enough for you.

For those who still can not get the point: if you use those functions,
you _definitely_ allow almost uncontrolled and poorly-logged outbound 
connections (you can make problem less obvious if you restrict some 
destination port numbers, but that does not actually solve it) and maybe
even some inbound ones.

I name socks as one of most dangerous (from "false sense of security" 
POV) pieces of firewall software. Don't use it if you don't understand
remote sockets interface concept and its side effects.

                                     _     _  _  _  _      _  _

---

From: "Michael B. East" <[email-masked]>
Date: Thu, 06 Jan 2000 22:17:06 -0500

I have installed fwtk 2.1 on a Sun Solaris 2.6 server. All is well except that all
mail  to users outside of the firewall that are invalid have the bounces directed
to the mail admin account. I'm using sendmail as the mailer on the server.

i.e. if mbeast emails to a valid user outside, all replies and the From field are
fine - mbeast. if mbeast emails to an invalid user but to a valid domain or to a
totally invalid domain, the bounce from the other system or from the server itself
is directed to eastfx-adm instead of mbeast.

Any ideas? Probably a setuid problem somewhere but I couldn't figure this out.

Michael East