Subject: smap+yao patches compilation error

From: "Alvaro Muñoz-Aycuens Mtnz." <[email-masked]>
Date: Thu, 27 Jan 2000 14:18:08 +0100

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello all, i have get compilation errors on a fwtk2.1 on linux, when
compliling smap with yao patches.
I get the following error:
 /tmp/fwtk/smap/smap.c:2049: undefined reference to 'res-query'
undefined collect2: ld returned 1 exist status
make[1]: leaving directory

Any ideas, thanks in advance

-- 
Alvaro Muñoz-Aycuens Martinez
El Argonauta Virtual
C\Gaztambide 9
28015 Madrid Spain
[email-masked]

"Hacking is not about answers. Hacking is about the path you take to
find
 the answers." --ReDragon

KeyID 2048/0xA1378C19
Fingerprint BB E8 6D 56 83 4A 3A 9E D2 12 2F AA AB 9F 76 72
PGP Key Available at http:\\alvarom.freeshell.org/pgp.html

---

From: "Alexander Waller" <[email-masked]>
Date: Thu, 27 Jan 2000 14:39:40 +0100

modifiy in Makefile.config AUXLIB= -lcrypt -lgdbm -lresolv
then it should work.

I solved that problem recently that way !

Alex.

+------------------------------------------+
+ Alex Waller                              +
+ WebPoint                                 +
+ Internet-Services                        +
+ A-6840 Götzis                            +
+ Mobil +43 676 4121128                    +
+ http://www.webpoint.at                   +
+------------------------------------------+

PGP-KEY : http://city.webpoint.at/pgp/pgp_aw.htm

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]]Im
Auftrag von Alvaro Muñoz-Aycuens Mtnz.
Gesendet: Donnerstag, 27. Jänner 2000 14:18
An: [email-masked]
Betreff: smap+yao patches compilation error

[To be removed from this list send the message "unsubscribe fwtk-users" in
the
BODY of a mail message to [email-masked].]

KeyID 2048/0xA1378C19

---

From: Penty Wenngren <[email-masked]>
Date: Thu, 27 Jan 2000 14:57:02 +0100

> make[1]: leaving directory

I think that if you add -lresolv to the Makefile it will work.

-- 

Penty Wenngren // Graphium Norstedts Tryckeri AB