Subject: Re: RTSP, Realaudio, and fwtk help

From: "Naresh Narang" <[email-masked]>
Date: Fri, 14 Jan 2000 11:22:34 IST

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I think you should change your this line in inetd.conf:

rtsp    stream    tcp    nowait    root    /usr/local/sbin/rtspd rtsp

to

rtsp    stream    tcp    nowait    root    /path/to/netacl    rtsp

It should work. I have not installed it yet, but I intend to. I am a novice 
to FWTK so please correct me if I am mistaken.

Regards,
N.K. Narang

----Original Message Follows----
From: Jennifer Tippens <[email-masked]>
To: [email-masked]
Subject: RTSP, Realaudio, and fwtk help
Date: Thu, 13 Jan 2000 13:20:46 -0600

[To be removed from this list send the message "unsubscribe fwtk-users" in 
the
BODY of a mail message to [email-masked].]

Hello,
We are using the fwtk and I was asked to find a RealAudio proxy for our 
system.
I downloaded the Real Time Streaming Protocol Proxy reference 
implimentation.  I
compiled and "installed" it.  That worked fine, but now how do I configure 
it for
use?  I gave it my (several times) best guess and this is what I came up 
with
(which doesn't work)

Added in netperm-table:
rtsp: permit-hosts 192.168.1.* -exec /usr/local/sbin/rtspd

Added in /etc/services:
rtsp:    554/tcp

Added in inetd.conf:
rtsp    stream    tcp    nowait    root    /usr/local/sbin/rtspd    rtsp

I have no idea what I'm supposed to do with it-- I have looked everywhere 
for
some (anything) information, contacted RealAudio, got on the
comp.security.firewalls newsgroup, read a book and I have gotten nowhere and
found nothing except a vague reference on the patches and add-ons page for 
fwtk
that says to download the rtspd proxy kit.  Am I even close?  Please help.

Thank you,
Jennifer

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Jennifer Tippens <[email-masked]>
Date: Fri, 14 Jan 2000 17:11:58 -0600

OK,  to use it as is, which I do understand is not recommended, I remove entry from
inetd.conf and /etc/services.  And I leave the entry in netperm-table, then run
it?  From a startup script?
-Jennifer

Ted Keller wrote:

> This solution will not work.  The real audio proxy must run in daemon
> mode.  Running it from netacl - or from inedt will not work.
>
> ted keller - bfg.com
>
> On Fri, 14 Jan 2000, Naresh Narang wrote:
>

---

From: Ted Keller <[email-masked]>
Date: Mon, 17 Jan 2000 10:29:36 -0500 (EST)

Jennifer,

Sorry, I've been out for a few days.  Yes - just run it from your startup
script.

ted keller

---

From: Ted Keller <[email-masked]>
Date: Fri, 14 Jan 2000 16:53:06 -0500 (EST)

ted keller - bfg.com