Subject: Re: ftp-gw partialy solved problem

From: Donald J Smith <[email-masked]>
Date: Wed, 26 Jan 2000 09:19:03 -0700

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

At 09:58 AM 1/25/00 -0500, you wrote:
>[To be removed from this list send the message "unsubscribe fwtk-users" in
the
>BODY of a mail message to [email-masked].]
>
>okay,
>I finaly got ftp-gw to work (somewhat) I am able to connect to the proxy,
>authenticate etc..
What changes did you make?
Are you running it as a daemon now or still out of inetd?

>BUT when I try a user [email-masked] I get the following
>
>[root@tmp1-6606 /root]# ftp ftp.newmg.net
>Connected to stratus.newmg.net.
>220-Proxy first requires authentication
>220 tmp1-6606.rochester.rr.com FTP proxy (Version V2.1) ready.
>Name (ftp.newmg.net:yacketta): yacketta
>331 Enter authentication password for yacketta
>Password:
>230 User authenticated to proxy
>ftp> user [email-masked]
>331-(----GATEWAY CONNECTED TO 10.100.100.1----)
>331-(220-Proxy first requires authentication)
>331-(220 tmp1-6606.rochester.rr.com FTP proxy (Version V2.1) ready.)
>331 Enter authentication password for yacketta
>Password:
>230 User authenticated to proxy
>ftp> ls
this sounds like the command port isn't getting linked up. There is a
discussion about ports and ftp-gw on
the faq. http://www.fwtk.org/fwtk/faq/
>500 must be connected to remote server
>ftp: bind: Address already in use
sounds like you might be running an ftp server out of both inetd.conf and
/etc/rc.d/rc3.d/S99local as daemon.
When bind complains about port in use that is usually the cause.
>ftp>
>
>what am I doing wrong here?
>the fwtk sits between my cable modem and my internal net (which has 2 98
>boxes and another linux box server httpd/ftpd)
>
>any help would be grealy appreciated
>Ron
>
>
>
------------------------------------------------------------------------------
Don Smith                               General Dynamics Information Systems
Systems Administrator                   8005 South Chester St
                                        EngleWood, Co. 80112
Phone (303) 649-7554
FAX   (303) 649-7504			[email-masked]
Error msgs that I love: 
"Keyboard not found press F1 to continue" (pc bios)
"Harddrive controller failure insert new disk and press any key to
continue" (pc bios)
"The disk is write protected Remove the write protect or
 use another disk." (nt)
User must change his password before he logs in the first time. (nt)
------------------------------------------------------------------------------

---

From: "Ronald J. Yacketta" <[email-masked]>
Date: Wed, 26 Jan 2000 11:45:14 -0500 (EST)

> Are you running it as a daemon now or still out of inetd?

running it from inetd

> >230 User authenticated to proxy

hrm.. will check the faq