Subject: yao-smap.pch

From: "Carl Blosser" <[email-masked]>
Date: Fri, 04 Feb 2000 08:52:22 PST

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

After, installing the patch I couldn't send mail to outside hosts.

This is the error I received

551 Recipient must be in the local domain(s).

And in /var/log/messages
the error just said Mail not local

TIA
Carl Blosser

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Penty Wenngren <[email-masked]>
Date: Fri, 04 Feb 2000 19:53:51 +0100

Michel Bardiaux wrote:
> Carl Blosser wrote:
> You have to use *two* smap executables: unpatched for outgoing mail,
> i.e.
> SMTP requests from internal net; patched for incoming SMTP requests.
> 

I really don't think so, or else I have misconfigured my smap awfully.
This is what my netperm-table looks like and this works just fine in
both directions.

smap, smapd:    userid mail
smap, smapd:    directory /var/spool/smap
smapd:          executable /usr/local/etc/smapd
smapd:          sendmail /usr/sbin/sendmail
smap:           timeout 3600
smap: check-from-address 1
smap: check-user-address 1
smap: domains domain.com
smap: hosts 10.10.10.*
smap: require-full-email 1

-- 

Penty Wenngren // Graphium Norstedts Tryckeri

---

From: "Johann G. Hautzinger" <[email-masked]>
Date: Mon, 07 Feb 2000 07:29:06 +0100

> the error just said Mail not local
hi,

there are several new options for the netperm-table (you can find them
documented in the source)

i am using the following:

smap:           check-from-address 1
smap:           permit-domains mydomain.at
smap:           permit-hosts mymailserver.mydomain.at its.ip.add.ress
smap:           require-full-email 1

hth

Hannes

-- 
Johann Georg Hautzinger,  email: [email-masked],  Tel.: 531 00 1907
Erste Bank AG - OE 0423 - Orga./Entw. Treasury u. Orga.Wertpapier
Boersegasse 14, 1010 Wien            http://treasury.erstebank.at

---

From: Michel Bardiaux <[email-masked]>
Date: Mon, 14 Feb 2000 10:37:30 +0100

> smap: require-full-email 1

Thanks for correcting me. Plea: we set up FWTK1.3 without anti-relay,
later upgraded to FWTK2.0 still without anti-relay and trying to change
as little of the config files as possible, then later we had to install
anti-relay *in a hurry* after a relay-rape. So, I'm afraid we did not
take enough time to read the documentation...

Greetings.
-- 
Michel Bardiaux
UsrConsult S.P.R.L.  Rue Margot, 37  B-1457 Nil St Vincent
Tel : +32 10 65.44.15  Fax : +32 10 65.44.10