Subject: problems with yao patch for smap

From: Schlienger Thomas <[email-masked]>
Date: Wed, 16 Feb 2000 15:52:08 +0100

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi

I have some trouble with the yao smap patch. Patching the source version 2.1
worked fine. Also compilation was successfully. But when I replaced smap
with the patched version, no mail went out or came in anymore. I can see the
process of smap, but if I telnet to port 25 there is no answer from smap.

I run a linux system with kernel 2.2.7 on a pc box.

My netperm-table:

smap, smapd:    userid mail                       
smap, smapd:    groupid mail                      
smap, smapd:    directory /var/spool/smap         
smapd:          executable /usr/local/etc/smapd   
smapd:          sendmail /usr/sbin/sendmail       
smap:           timeout 3600

smap:	check-from-adress 1                        
smap: domains ourdomain.com                        
smap: hosts 172.16.0.1

Has anyone an idea or a solution to my problem?

Thanks in advance...

Thomas Schlienger
[email-masked]

---

From: Blair Lowe <[email-masked]>
Date: Wed, 16 Feb 2000 13:53:53 -0700

Hi,

Platform: RedHat 6.1
Software: fwtk 2.1

I cannot patch the smap.c file properly. Here is the command I used.

#patch < yao-smap.pch
patching file `smap.c'
Hunk #1 FAILED at 1.
1 out of 40 hunks FAILED -- saving rejects to smap.c.rej

What is a hunk, and more importantly what do I need to do to avoid this.

Thanks,
Blair.
Computer Engineering Inc.
http://www.compeng.net
Phone: 780 499 5687 (9 - 5 MST)
Fax:   780 435 0693 (24 Hours)

---

From: Blair Lowe <[email-masked]>
Date: Thu, 17 Feb 2000 14:40:36 -0700

Does fwtk close idle ports?

I am on RH 6.1/ fwtk 2.1.

Thanks,
Blair.

---

From: Ted Keller <[email-masked]>
Date: Thu, 17 Feb 2000 18:53:14 -0500 (EST)

Blair,

Idle ports should be closed when the proxy exits. This normally occurs
when the timeout values have been reached.

ted keller