Subject: smap/smapd/sendmail

From: [email-masked] (Stefan Heim, Dipl.-Ing.)
Date: Tue, 1 Feb 2000 10:51:09 -0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello,

I use smap/smapd and the mails are correct delivered from
the internal clients to external destinations. But after each
mail apears the following error messages in /var/adm/messages
on the FW-machine:

.....sendmail[477] AA00477: SYSERR: Who are you ?:No such file or directory
.....localhost smapd[476]: discard (OS error) pid=477 code=71

The settings are:
/usr/local/etc/netperm-table:

smap, smapd:    userid 4
smap, smapd:    directory /var/spool/smap
smapd:               executable /usr/local/etc/smapd
smapd:               sendmail /usr/sbin/sendmail
smap:                 timeout 3600

Temp directory for sendmail:
/var/spool/mqueue

-------
Thanks!

---

From: Michel Arboi <[email-masked]>
Date: 02 Feb 2000 12:39:22 +0100

> .....sendmail[477] AA00477: SYSERR: Who are you ?:No such file or directory

I think you should rather look in sendmail configuration.

> .....localhost smapd[476]: discard (OS error) pid=477 code=71

This happens if sendmails returns EX_OSERR or EX_OSFILE. 
man sendmail says :
     Sendmail returns an exit status describing what it did.  The codes are
     defined in <sysexits.h>:
/usr/include/sysexits.h:
 *	EX_OSERR -- An operating system error has been detected.
 *		This is intended to be used for such things as "cannot
 *		fork", "cannot create pipe", or the like.  It includes
 *		things like getuid returning a user that does not
 *		exist in the passwd file.
 *	EX_OSFILE -- Some system file (e.g., /etc/passwd, /etc/utmp,
 *		etc.) does not exist, cannot be opened, or has some
 *		sort of error (e.g., syntax error).