Subject: FTP error 425

From: "Lidgate, Chris A" <[email-masked]>
Date: Wed, 9 Feb 2000 05:15:41 -0600

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I've just seen an odd message that I've never seen before
and wondered if someone could shed some light on what was 
happening.

>From a browser, accessing ftp://ftp.adaptec.com I always
get this message from http-gw on our firewall.

	FTP Error- 425

	425 Can't build data connection: Connection refused.

However if I use command line ftp the connection works perfectly 
as the following transcipt shows.

	sun20{lidgaca} ftp firewall
	Connected to firewall.
	220-
	220-         Welcome to the FOO.COM ftp proxy.
	220-         =================================
	220-
	220-    ... Usual legal bollox here ...
	220 
	Name (firewall:expcl): [email-masked]
	331-(----GATEWAY CONNECTED TO ftp.adaptec.com----)
	331-(220 jester FTP server (Version wu-2.4.2-academ (1) Thu Apr 1 
		17:16:29 PST 1999) 	ready.)
	331 Guest login ok, send your complete e-mail address as password.
	Password:
	230-************************************************************
	230-*
	230-* Welcome to Adaptec's FTP Site.
	230-*
	230-* By downloading  software from  this site, you agree 
	230-* to Adaptec's  legal terms and  conditions described 
	230-* in this URL:

Obviusly http-gw is objecting to the site for some reason, but does
anyone know why ?

Our firewall is Linux based, and is running fwtk v2.1.

Regards,

Chris Lidgate.

---

From: Tony Gale <[email-masked]>
Date: Wed, 09 Feb 2000 12:18:45 -0000 (GMT)

Bizarre. I've only ever encountered this problem with a particular
broken version of IIS 4.

The included patch should fix this. Let me know how it goes.

Problem description:
        Some FTP servers don't like receiving commands split over
        multiple packets. They are broken.

avenger: a FAQ/patches candidate.

-tony

> Our firewall is Linux based, and is running fwtk v2.1.

---
E-Mail: Tony Gale <[email-masked]>
The average income of the modern teenager is about 2 a.m.

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Joseph S D Yao <[email-masked]>
Date: Fri, 11 Feb 2000 14:27:43 -0500

> 	425 Can't build data connection: Connection refused.

It is not clear from your message ... from Navigator's Manual Proxy
setup page, do you have HTTP and FTP's proxies both set to your
firewall, port 80?  This is the correct settings.

-- 
Joe Yao				[email-masked] - Joseph S. D. Yao
COSPO/OSIS Computer Support					EMT-B
-----------------------------------------------------------------------
This message is not an official statement of COSPO policies.