Subject: RE: FTP error 425

From: "Lidgate, Chris A" <[email-masked]>
Date: Thu, 10 Feb 2000 06:54:39 -0600

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi

Just to report that the Patch that Tony provided seems
to have done the trick. I made the changes to http-gw 
last night, was able to acces the troublesome site,
and have not seen any side effects through today.

I would recommend that this patch be included on the 
fwtk site.

I'd also like to extend my thanks to Tony for being
so quick off the mark in sorting this out. It's times 
like this that the value of open source software really
becomes apparent.

I've emailed the admin of ftp.adaptec.com to inform
them that it looks like there's something wrong with
their ftp server, but so far haven't got to talk to 
anybody technical enough to get the point across to. 
However it does look as though the problem that Tony
describes here is perhaps more prevalent amongst ftp
servers than Tony thought.

Thanks again,

Chris

> ----------
> From: 	Tony Gale[SMTP:[email-masked]]
> Sent: 	09 February 2000 12:18
> To: 	Lidgate, Chris A; [email-masked]
> Cc: 	[email-masked]
> Subject: 	RE: FTP error 425
> 
> <<File: fwtk-broken-ftp-svr.patch>>
> 
> Bizarre. I've only ever encountered this problem with a particular
> broken version of IIS 4.
> 
> The included patch should fix this. Let me know how it goes.
> 
> Problem description:
>         Some FTP servers don't like receiving commands split over
>         multiple packets. They are broken.
> 
> avenger: a FAQ/patches candidate.
> 
> -tony
> 
> 
> On 09-Feb-2000 Lidgate, Chris A wrote:
> > [To be removed from this list send the message "unsubscribe
> > fwtk-users" in the
> > BODY of a mail message to [email-masked].]
> > 
> > I've just seen an odd message that I've never seen before
> > and wondered if someone could shed some light on what was 
> > happening.
> > 
> >>From a browser, accessing ftp://ftp.adaptec.com I always
> > get this message from http-gw on our firewall.
> > 
> >       FTP Error- 425
> > 
> >       425 Can't build data connection: Connection refused.
> > 
> > However if I use command line ftp the connection works perfectly 
> > as the following transcipt shows.
> > 
> 
[snip]

---

From: "Lidgate, Chris A" <[email-masked]>
Date: Mon, 14 Feb 2000 05:04:38 -0600

Sorry,

Yes both my http and ftp proxies point to fwtk-firewall port 80.

I wasn't clear, but *most* ftp sites do work correctly,
it's just this specific one that doesn't. In case you haven't
seen the rest of this thread, Tony Gale provided me with a 
patch for http-gw that solved the problem.

The underlying problem (in Tony's words) is as follows:

Problem description:

Thanks for your help,

Chris

> ----------
> From: 	Joseph S D Yao[SMTP:[email-masked]]
> Sent: 	11 February 2000 19:27
> To: 	Lidgate, Chris A
> Subject: 	Re: FTP error 425
> 
> On Wed, Feb 09, 2000 at 05:15:41AM -0600, Lidgate, Chris A wrote:
> It is not clear from your message ... from Navigator's Manual Proxy
> setup page, do you have HTTP and FTP's proxies both set to your
> firewall, port 80?  This is the correct settings.
> 
> -- 
> Joe Yao				[email-masked] - Joseph S. D.
> Yao
> COSPO/OSIS Computer Support					EMT-B
> -----------------------------------------------------------------------
> This message is not an official statement of COSPO policies.
>