Subject: yao-smap.pch

From: Carl Blosser <[email-masked]>
Date: Thu, 3 Feb 2000 13:04:07 -0700

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

When I try and compile the smap.c after running patch < yao-smap.pch this is
the error I get
cc -I.. -g    -c smap.c -o smap.o
cc -g -o smap smap.o arpadate.o ../libfwall.a
smap.o: In function `from_address_ok':
/usr/local/etc/fwtk/smap/smap.c:2006: undefined reference to `res_query'
/usr/local/etc/fwtk/smap/smap.c:2006: undefined reference to `res_query'
collect2: ld returned 1 exit status
make: *** [smap] Error 1         
Any help would be apprecitated.

TIA
Carl Blosser, MCSE CCNA
NT/Network Administrator 
SKLD Information Services
720 S. Colorado Blvd, Suite 1000N
Denver, CO 80246
303-820-0870
[email-masked]

---

From: Ted Keller <[email-masked]>
Date: Thu, 3 Feb 2000 18:56:29 -0500 (EST)

Carl,

Looks like you have to add the -lresolv to your make file to pick up the
resolver library modules.

ted keller