Subject: POP3/pop3-gw/plug-gw/pop-gw

From: Darren Ehmke <[email-masked]>
Date: Tue, 21 Mar 2000 22:52:10 -0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi,

	Have been using the fwtk for about a year now, which works like a champ.
We had not enabled mail to go through the fwtk, but recently decided that it
would help what we were doing.  Anyway,  I have not found good answers to
the questions and problems we have encountered in setting up pop mail.
(some of these questions are here for others to read so as to answer
other peoples questions as well.)

question #1. Does fwtk support pop mail, obvious answer is yes.

question #2. Does the fwtk have the ability to use the fwtk as
	     as a gateway to an outside POP server?  I think so,
             although I have not read anything that says so.

question #3. Can the fwtk be used to only work as a gateway to
<unanswered> an outside pop server?  As in, can it easily be
             configured and maintained to allow on a port
             to outside pop server to send and use the outside
             pop server, so as to not use a mail server on
             the fwtk.  The same for receiving pop mail.  As in,
             the ability to receive pop mail where the fwtk
             computer is not used to as a temporary location
             and then sent.

question #4. There seems to be 3 different ways to possibly set
<unanswered> this up.
             a. pop3-gw  (appears that docs say only outbound,
                          does this mean you can not receive?)
             b. pop-gw   (only used for internal pop server?)
             c. plug-gw  (??)

	I have taken approached (a) and (c) to try to configure the
system to appropriately receive and send pop mail.  At one time
it did work for receiving pop mail with approach (a).  But,
after I tried to send pop mail out, it failed completely and
miserably.  Where I keep receiving deny messages with the /var/log/messages
file.

Here is the configuration of how I set it up.

Before going there, md5 needed to be compiled in.  I had found
the libmd5, but it did not work.  So, I did find the md5
that libmd5 had referred to, where the md5.c and md5.h were
available.  Hacking the pop3-gw.c program and the Makefile
to include "md5.h" instead of <md5.h> and putting this in
its current directory and changing the Makefile to include
md5.o within the compiling.

Now for the configuration.

SERVER CONFIGURATION

/etc/inetd.conf
pop3 stream tcp nowait root /usr/local/etc/pop3-gw pop3-gw pop3

/etc/services
did not modify anything
pop3  110/tcp
pop3  110/udp

/usr/local/etc/netperm-table
pop3-gw:	timeout 300
pop3-gw:	port pop3 permit-hosts 10.* -plug-to mail.location.com -port pop3

Within Netscape on a client system, the following was done.

CLIENT CONFIGURATION

Edit->Preferences->Identity
	Email Address: [email-masked]

Edit->Preferences->Mail Servers
	Incoming Mail Servers
		Server Name: fwtkcomputer.domainname.com
		User Name: [email-masked] 110

	Outgoing Mail (SMTP) Server: fwtkcomputer.domainname.com
	Outgoing Mail Server user name: [email-masked] 110

ERROR MESSAGES

In /var/log/messages

Mar 21 10:53:22 phaze pop3-gw[5138]: deny host=sam/10.60.1.120
service=110

On Netscape

An error occurred with the pop3 server.  You
should contact the administrator for this 
server or try again later.

	Any suggestions, comments and other would be very greatly
appreciated.

Thanks

Darren

---

From: [email-masked]
Date: Wed, 22 Mar 2000 14:32:07 +0300

-----BEGIN PGP SIGNED MESSAGE-----

nuqneH,

>                           does this mean you can not receive?)

Outbound means it is not recommended for serving requests from
untrusted networks.

> miserably. 

You cannot _send_ pop mail out. pop3 is protocol to _receive_ mail.
You shound use SMTP for it.

> Where I keep receiving deny messages with the /var/log/messages
> file.
> 

I assume you are running Linux ;)? Ok, looks like you did that right way.

> pop3 stream tcp nowait root /usr/local/etc/pop3-gw pop3-gw pop3

extra "pop3" is not needed. you should not use plug-gw syntax here.
 
> pop3  110/udp

Ok.

> pop3-gw:	port pop3 permit-hosts 10.* -plug-to mail.location.com -port pop3

RTFM. You should not use plug-gw syntax here. pop3-gw does not find
configuration tag "hosts" (you have "port" instead) and assumes everything
is denied.
 
> 		User Name: [email-masked] 110

RTFM. a) you should use plug-to or user@host syntax, using both of them
is pure nonsense. b) it may do not affect you for this configuration 
because of netscape mail client misfeature/bug (see -separator option).
Remove "110", it is not required and you used incorrect syntax anyways. 
 
> 	Outgoing Mail Server user name: [email-masked] 110

110 has nothing to do with SMTP stuff, nor pop3-gw does.

> 	Any suggestions, comments and other would be very greatly

                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!

---

From: Uncle George <[email-masked]>
Date: Wed, 22 Mar 2000 08:39:05 -0500

Where is pop3-gw. I thought I have gotten the latest FWTK 2.0+ ( from the file
 CHANGES ), for which pop3-gw doesn't exist!
gat

---

From: Darren Ehmke <[email-masked]>
Date: Sat, 25 Mar 2000 21:45:51 -0800

Hi,

	Thanks for the info, but still having some problems.  I have changed the configuration pieces to try to correctly setup the client and proxy.  The error that results in the /var/log/messages file is something like "authentication failure to host",
which lists the mail server on the outside.  From what the manual says, it should correctly work.  It appears that it is trying, but keeps asking for a password to be typed in to verify.  Below lists the changes.

> extra "pop3" is not needed. you should not use plug-gw syntax here.

Removed the pop3, so now reads.  Should the second pop3-gw be there?
/etc/inetd.conf
pop3 stream tcp nowait root /usr/local/etc/pop3-gw pop3-gw

> configuration tag "hosts" (you have "port" instead) and assumes everything

RTM, this is what is now there.
/usr/local/etc/netperm-table
pop3-gw:      timeout 300
pop3-gw:      permit-hosts 10.* -plug-to mail.location.com

> Remove "110", it is not required and you used incorrect syntax anyways.

Removed the 110 port, so that only [email-masked] is present.  The fwtkcomputer.domain.com is the same.

> -----BEGIN PGP SIGNATURE-----
> Version: 2.6.3i
> Charset: noconv
> 
> iQCVAwUBONivNqH/mIJW9LeBAQGxNgP/UtMUW3nKRwyALjv4qEGyjdmrFo/J4ncS
> PKtwDpdswo1kff8zUAt4/4T8EIslt/dDri1NJ/XEd+Jrxum8HqqKETV2Pt12EeA1
> 4CchzNaIocYpKdL78RqzrsxZMJRIHMDjKG4bDGO0QjWn5NjH+TOmOHUJ3VUAqbfv
> shtitRVYv20=
> =r6ez
> -----END PGP SIGNATURE-----