Subject: a problem in analysing the source

From: jungu zhan <[email-masked]>
Date: Wed, 8 Mar 2000 17:56:23 -0800 (PST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

HI:
I got a problem in analysing the source code of
fwtk_v1.3.

In "http-gw.c",line 726,there are "if(buf[x] == IAC)".
"IAC" also appears many times in other files, such as
"http-gw.c", "tn-gw.c", but I can't find the
definition of "IAC" in all the source files. I'm
puzzled.

Can anyone provide a answer?
Thanks a lot.

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

---

From: "Joseph Judge" <[email-masked]>
Date: Wed, 8 Mar 2000 21:38:14 -0500

Should be a system include file /usr/include/arpa/telnet.h
(or something).

IAC = "interpret as command" -- part of the telnet protocol
that allows the communications channel to be used for
sending 'control' info back and forth. 

This way, telnet -- at first connect -- can send a "IAC I-will
handle-echoing" and the other end can say "IAC I-won't echo"
-- so client/server can negotiate.

Interesting note --- if you are a mail transport (e.g. sendmail)
and see "IAC<char><char>", then someone it using telnet to 
connect to your service socket :-)

	-joe

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of jungu zhan
> Sent: Wednesday, March 08, 2000 8:56 PM
> To: [email-masked]
> Subject: a problem in analysing the source 
> 
>

---

From: Rick Murphy <[email-masked]>
Date: Wed, 08 Mar 2000 21:09:58 -0500

>I got a problem in analysing the source code of

FWTK 1.3 is ancient. Chances are wherever you copied the kit from has an 
unauthorized copy. Please ask the archive site to remove it, then get a 
copy of FWTK 2.1.

>definition of "IAC" in all the source files. I'm

IAC is the TELNET command introducer character.  Usually defined in 
/usr/include/arpa/telnet.h - whatever OS you're using may not include 
telnet.h automatically; adding "#include <arpa/telnet.h>" to the end of the 
includes in the two sources may help.
         -Rick