Subject: ftp-gw option or command

From: wen <[email-masked]>
Date: Tue, 11 Apr 2000 10:57:30 +0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

hello all:
    in ftp-gw.c,there is struct FtpOp ops[]= {
"port",OP_CONN,cmd_port,
 "user",OP_AOK|OP_WCON,cmd_user,
 "retr",OP_CONN|OP_XTND,0,
 "stor",OP_CONN|OP_XTND,0,
 "pass",OP_AOK|OP_WCON,cmd_response,
 "cwd",OP_CONN,0,
 "pwd",OP_CONN,0,
       
     ;
     ;
     ;   
     ;
   0,              0,                              0
};

the left line(eg:port,pass etc) is ftp-gw command or ftp-gw configure option for netperm-table?
if these is ftp-gw command,why  not to run after "ftp>" prompt?

thanks.

wen

---

From: Rick Murphy <[email-masked]>
Date: Tue, 11 Apr 2000 06:18:22 -0400

>if these is ftp-gw command,why  not to run after "ftp>" prompt?
They're FTP commands - commands that are part of the FTP protocol. They're 
not the same as the user commands. For example, with normal ftp if you give 
the 'GET a.a' command, the ftp user agent sends RETR then PORT. (I may be 
misremembering the order.)
The options modify the requirements for a command. You've got to have a 
connection to an FTP server to use RETR; USER doesn't require a connection 
(OP_WCONN). Commands subject to extended permissions (time of day, etc.) 
have OP_XTND set.
         -Rick

---

From: [email-masked]
Date: Tue, 11 Apr 2000 14:47:09 +0400

-----BEGIN PGP SIGNED MESSAGE-----

nuqneH,

> the left line(eg:port,pass etc) is ftp-gw command or ftp-gw configure option for netperm-table?

ftp-gw command.

> if these is ftp-gw command,why  not to run after "ftp>" prompt?

? it is the command ftp client sends to a server or ftp-gw. 

                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!