Subject: Re: http-gw on redhat 6.1 - cgi problem

From: Derek Smith <[email-masked]>
Date: Mon, 03 Apr 2000 00:35:33 +0100

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi all,

Sorry about the delay, but I've been trrying all the suggestions from this group,
plus a few experiments of my own...

As requested here's the output from the script suggested:

icmp_destunreach_rate:    100
icmp_echo_ignore_all:    0
icmp_echo_ignore_broadcasts:    0
icmp_echoreply_rate:    0
icmp_ignore_bogus_error_responses:    0
icmp_paramprob_rate:    100
icmp_timeexceed_rate:    100
igmp_max_memberships:    20
ip_always_defrag:    0
ip_autoconfig:    0
ip_default_ttl:    64
ip_dynaddr:    0
ip_forward:    0
ip_local_port_range:    1024    4999
ip_masq_debug:    0
ip_no_pmtu_disc:    0
ipfrag_high_thresh:    262144
ipfrag_low_thresh:    196608
ipfrag_time:    30
tcp_fin_timeout:    180
tcp_keepalive_probes:    9
tcp_keepalive_time:    7200
tcp_max_ka_probes:    5
tcp_max_syn_backlog:    128
tcp_retrans_collapse:    1
tcp_retries1:    7
tcp_retries2:    15
tcp_rfc1337:    0
tcp_sack:    1
tcp_stdurg:    0
tcp_syn_retries:    10
tcp_syncookies:    0
tcp_timestamps:    1
tcp_window_scaling:    1

I tried the same on the redhat 5 machine, but the output was so wildly different
that I got no clues - I hope that this is informative.

I've tried it with an etherlink Pro 100 and a 3com 3c509 with no difference
between the two.

Thanks,
Derek

Donald J Smith wrote:

> At 11:10 AM 3/23/00 +0000, Derek Smith wrote:
> >[To be removed from this list send the message "unsubscribe fwtk-users" in
> the
> >BODY of a mail message to [email-masked].]
> >
> >Hi,
> >
> >I've been running tis on redhat 5 for about a year with no real
> >problems.  When I recently upgraded to 6.1 I found that the http-gw was
> >having problems handling sites with cgi scripts, failing with a message
> >to the user "connection reset by peer" although the amount of data
> >passed as recorded in the logs was the same for both 5 and 6.1.
> >
> >The problem occurs whether the http-gw is run from inetd, or as a
> >daemon.
> How about something like a listing of you network configuration try
> cd /proc/sys/net/ipv4
>
> for i in `ls -1`
>  do
> echo $i >> /tmp/netconfig.out
>  cat $i >> /tmp/netconfig.out
>  done
> this should provide a better clue as to how your network is configured.
>
> >
> >The same symptoms show with both Netscape and IE.
> >
> >I haven't been able to find any mention of this problem on redhat sites,
> >or tis faq's, so any suggestions / comments would be very welcome.
> >
> >Thanks,
> >
> >Derek
> >
> >
> ------------------------------------------------------------------------------
> Don Smith                               General Dynamics Information Systems
> Systems Administrator                   8005 South Chester St
>                                         EngleWood, Co. 80112
> Phone (303) 649-7554
> FAX   (303) 649-7504                    [email-masked]
> Error msgs that I love:
> "Keyboard not found press F1 to continue" (pc bios)
> "Harddrive controller failure insert new disk and press any key to
> continue" (pc bios)
> "The disk is write protected Remove the write protect or
>  use another disk." (nt)
> User must change his password before he logs in the first time. (nt)
> ------------------------------------------------------------------------------

---

From: Tony Gale <[email-masked]>
Date: Mon, 03 Apr 2000 09:23:43 +0100 (BST)

Did you try the patch that was sent to you that will solve this
problem, which, incidentally, is included in the FAQ? I've included it
again.

-tony

>> >or tis faq's, so any suggestions / comments would be very

---
E-Mail: Tony Gale <[email-masked]>
index, n.:
	Alphabetical list of words of no possible interest where an
	alphabetical list of subjects with references ought to be.

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Derek Smith <[email-masked]>
Date: Mon, 03 Apr 2000 17:34:58 +0100

Hi all,

OK, "It's a fair cop" - I tried the patch on our 6.0 machine which was also
exhibiting the same problems, but I hadn't tried it on the 6.1 machine which is
our live system - I've now installed it on the live machine and sure enough it's
working fine.

Apologies for my density in this,
and many thanks to Tony & Ko for beating me around the head with the answer until
I gave it a proper try!

Cheers everybody,
Derek

Tony Gale wrote:

>   ------------------------------------------------------------------------
>                             Name: fwtk-ns-post.patch
>    fwtk-ns-post.patch       Type: unspecified type (application/octet-stream)
>                         Encoding: base64
>                      Description: fwtk-ns-post.patch