Subject: Can you please help

From: Jonathan Peers <[email-masked]>
Date: Thu, 06 Apr 2000 18:58:40 +0200

I type make and it comes back with the below ..... I have att my
Makefile.config

Thank you 
jonathan

make[1]: Entering directory `/home/jonathanp/fwtk/smapd'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/smapd'
all: /home/jonathanp/fwtk/netacl
make[1]: Entering directory `/home/jonathanp/fwtk/netacl'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/netacl'
all: /home/jonathanp/fwtk/plug-gw
make[1]: Entering directory `/home/jonathanp/fwtk/plug-gw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/plug-gw'
all: /home/jonathanp/fwtk/ftp-gw
make[1]: Entering directory `/home/jonathanp/fwtk/ftp-gw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/ftp-gw'
all: /home/jonathanp/fwtk/tn-gw
make[1]: Entering directory `/home/jonathanp/fwtk/tn-gw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/tn-gw'
all: /home/jonathanp/fwtk/rlogin-gw
make[1]: Entering directory `/home/jonathanp/fwtk/rlogin-gw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/rlogin-gw'
all: /home/jonathanp/fwtk/http-gw
make[1]: Entering directory `/home/jonathanp/fwtk/http-gw'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jonathanp/fwtk/http-gw'
all: /home/jonathanp/fwtk/x-gw
make[1]: Entering directory `/home/jonathanp/fwtk/x-gw'
cc -I.. -g -DLINUX -I/usr/X11/include   -c dialog.c -o dialog.o
In file included from dialog.c:12:
ulib.h:26: X11/Intrinsic.h: No such file or directory
dialog.c:14: X11/Xlib.h: No such file or directory
dialog.c:15: X11/Xatom.h: No such file or directory
dialog.c:16: X11/StringDefs.h: No such file or directory
dialog.c:19: X11/Xaw/Cardinals.h: No such file or directory
dialog.c:20: X11/Xaw/Paned.h: No such file or directory
dialog.c:21: X11/Xaw/Label.h: No such file or directory
dialog.c:22: X11/Xaw/Box.h: No such file or directory
dialog.c:23: X11/Xaw/Command.h: No such file or directory
make[1]: *** [dialog.o] Error 1
make[1]: Leaving directory `/home/jonathanp/fwtk/x-gw'
make: *** [all] Error 2
root@beta:/home/jonathanp/fwtk > 

-- 
Definition of Windows 95 : 
A 32 bit GUI, running on a 16 bit shell, running ontop of an 8 bit OS,
running on a 4 bit CPU, written by 2 bit Company, who can't stand 1 bit
competition.

-- 
Definition of Windows 95 : 
A 32 bit GUI, running on a 16 bit shell, running ontop of an 8 bit OS,
running on a 4 bit CPU, written by 2 bit Company, who can't stand 1 bit
competition.

#
#  Copyright (c) 1993, Trusted Information Systems, Incorporated
#  All rights reserved.
# 
#  Redistribution and use are governed by the terms detailed in the
#  license document ("LICENSE") included with the toolkit.
#

#
#	Author: Marcus J. Ranum, Trusted Information Systems, Inc.
#
# RcsId: "$Header: /home/rmurphy/fwtk/fwtk/RCS/Makefile.config.linux,v 1.2 1998/01/13 23:50:46 rmurphy Exp $"

# Your C compiler (eg, "cc" or "gcc")
CC=	cc

# program to use for installation -- this may or may not preserve
# old versions (or whatever). assumes that it takes parameters:
# copy source dest
CP=	cp

# Defines for your operating system
#
DEFINES=-DLINUX
#DEFINES=-DSYSV -DSOLARIS

# Options for your compiler (eg, "-g" for debugging, "-O" for
# optimizing, or "-g -O" for both under GCC)
#COPT=	-g -traditional $(DEFINES)
COPT=	-g $(DEFINES)
#COPT=	-O $(DEFINES)

# Version of "make" you want to use
#MAKE=	gnumake
MAKE=	make

# Your ranlib utility (use "touch" if you don't have ranlib)
RANLIB=	ranlib
#RANLIB=	touch

# Destination directory for installation of binaries
DEST=	/usr/local/etc

# Destination directory for installation of man pages
#DESTMAN=	$(DEST)/../man

# Names of any auxiliary libraries your system may require (e.g., -lsocket)
# If you want to link against a resolver library, specify it here.
AUXLIB=
#AUXLIB= -lsocket
# Some versions of Linux have broken the crypt() function out into a
# separate library - uncomment the following line if authsrv fails to build.
AUXLIB= -lcrypt

# For Solaris:
#AUXLIB= -lresolv -lsocket -lnsl

# DBM library should be specified if it is an external library or
# you with to use a different one than what is included in libc
#DBMLIB=	-lndbm
# for Linux:
DBMLIB=-lgdbm
# "Linux" is such a ephemeral concept. Unfortunately, one of the
# significant incompatibilities between distributions and versions
# is where the DBM libraries end up. "-ldbm", "-ldb", or "-lgdbm" could
# work for you.  "-lgdbm" works for me (Slackware Linux 2.3).
# for BSD:
#DBMLIB=

# Flags to pass to the linker (eg, -static for static binaries under GCC,
# or -Bstatic for static binaries under SunOS 4.1.x)
#LDFL=	-Bstatic
#LDFL=
LDFL= -g -static
# Flags for X gateway link - usually the same as LDFL
XLDFL=-g

# Location of the fwtk sources [For #include by any external tools needing it]
FWTKSRCDIR=/u/b/mjr/firewall/fwtk
#FWTKSRCDIR=/usr/local/src/fwtk

# Location of X libraries for X-gw
XLIBDIR=/usr/X11/lib
#XLIBDIR=/usr/local/X11R5/lib

# X Libraries
# For BSD:
#XLIBS= -L$(XLIBDIR) -lXaw -lXmu -lXt -lXext -lX11 -lSM -lICE -lipc
#XLIBS =  -L$(XLIBDIR) -lXaw -lXmu -lXt -lXext -lX11
# for Linux:
XLIBS =  -L$(XLIBDIR) -lXaw -lXmu -lXt -lXext -lX11 -lc
# for BSD/OS 2.0:
#XLIBS = -L$(XLIBDIR) -lXaw -lXmu -lXt -lXext -lX11 -lSM -lICE -lXext
# For SunOS:
#XLIBS = -L$(XLIBDIR) -lXaw -lXmu -lXt -lXext -lX11

# Location of X include files
#XINCLUDE=/usr/X11R6/include/X11/Xaw3d
XINCLUDE=/usr/X11/include
#XINCLUDE=/usr/local/X11R5/include

# Objects to include in libfwall for SYSV
SYSVOBJ= signal.o

---

From: Tony Gale <[email-masked]>
Date: Thu, 06 Apr 2000 15:17:19 +0100 (BST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Looks like you didn't install the X11 development packages. Either
that or the header files aren't under /usr/X11/include which is where
you've set them to be.

-tony

> root@beta:/home/jonathanp/fwtk > 

---
E-Mail: Tony Gale <[email-masked]>
QOTD:
	"Who?  Me?  No, no, NO!!  But I do sell rugs."

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Donald J Smith <[email-masked]>
Date: Thu, 06 Apr 2000 10:53:49 -0600

>all: /home/jonathanp/fwtk/netacl
CUT several lines of the same make "errors"
>make[1]: Entering directory `/home/jonathanp/fwtk/x-gw'
Heres where your real errors begin the other errors simply say that the
required files 
are all uptodate.
>dialog.c:23: X11/Xaw/Command.h: No such file or directory
This clearly says that your /usr/lib/X11/Xaw/ is missing files (or the
whole directory is missing either)
When I install the fwtk I NEVER add the X stuff to my os. But I will ALWAYS
get errors from the make 
unless I comment out the x-gw stuff. Since I don't gateway X in or out of
my firewall this is acceptable to me.
In fact sometimes I comment out all but ftp and smap stuff cause those are
the two I ALWAYS use.
I removed most of the rest of this message but will made a few comments to
hopefully help you.
Look for #########################

># Location of the fwtk sources [For #include by any external tools needing
it]
############################################################################
#############
THIS is WRONG. It is MarcusRathum's home directory. Your version of fwtk
resides in /home/jonathanp/fwtk/smapd. djs
############################################################################
#############
># Location of X libraries for X-gw
############################################################################
###############
This maybe wrong or you may not have loaded Xlibs at all. djs
############################################################################
###############
># Location of X include files
############################################################################
###############
This maybe wrong or you may not have loaded Xlibs at all. djs
############################################################################
###############
># Objects to include in libfwall for SYSV
------------------------------------------------------------------------------
Don Smith                               General Dynamics Information Systems
Systems Administrator                   8005 South Chester St
                                        EngleWood, Co. 80112
Phone (303) 649-7554
FAX   (303) 649-7504			[email-masked]
Error msgs that I love: 
"Keyboard not found press F1 to continue" (pc bios)
"Harddrive controller failure insert new disk and press any key to
continue" (pc bios)
"The disk is write protected Remove the write protect or
 use another disk." (nt)
User must change his password before he logs in the first time. (nt)
------------------------------------------------------------------------------