Subject: Compiling 2.1 on RH 6.2

From: "Nixon, Anthony" <[email-masked]>
Date: Thu, 27 Apr 2000 16:01:29 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I am presently having problems compiling the auth module of FWTK 2.1 on RH
6.2 (Intel). The error I get states:

cc -I.. -g -DLINUX  -c -o db.o db.c
db.c:16: ndbm.h: No such file or directory
Make[1]: *** [db.o] Error 1

I am assuming this pertains to issue 1.3.1: "fwtk/auth/db.c:66: undefined
reference to `dbm_open'" errors in the FWTK FAQ. I have confirmed that gdbm
and gdbm-development rpms are installed and the library file (per the FAQ)
/usr/lib/libgdbm.a is present. I have also recompiled gdbm and still no
luck. Any and all help would be greatly appreciated.

Shon

---

From: Bill Faust <[email-masked]>
Date: Thu, 27 Apr 2000 13:34:39 -0700 (PDT)

Just went through this last week.  Attached below are the patches I made
to enable it to find ndbm.h on my RedHat 6.2 system.  Simply add 'gdbm/'
to the includes in the three files authdum.c authload.c db.c.

There are a few threads in this mailing list discussing this issue.

Hope this is helpful.

--
Bill Faust
Optim Microwave
818-865-8157

-----------------------------
patches/authdump.c.diff
-----------------------------
16c16
< #include      <ndbm.h>
---
> #include      <gdbm/ndbm.h>

-----------------------------
patches/authload.c.diff
-----------------------------
16c16
< #include      <ndbm.h>
---
> #include      <gdbm/ndbm.h>

-----------------------------
patches/db.c.diff
-----------------------------
16c16
< #include      <ndbm.h>
---
> #include      <gdbm/ndbm.h>