Subject: Problem with accessing one ftp site through http-gw

From: Jon Earle <[email-masked]>
Date: Thu, 06 Apr 2000 07:31:58 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello,

I've a fwtk2.1 box, patched with ipbind 1.2, and the relevant patches for 
http-gw from the fwtk.org site.  I even patched it with the old (but still 
useful) ftp continuation line patch, which is no longer on the main fwtk 
patch list.

If I try to access ftp.novatel.com, I get Error 501. The site works fine if 
I ftp to it through ftp-gw, but fails through http-gw.  Other ftp sites 
work properly through http-gw.  The site works properly without an http-gw 
proxy in the way.  I've confirmed this at three different locations, one 
running an older version of ipbind, one running the current, and one not 
running it at all.  All have the other http-gw patches.

Any thoughts?

Cheers!
Jon

---

From: Tony Gale <[email-masked]>
Date: Thu, 06 Apr 2000 13:11:53 +0100 (BST)

Apply the enclosed patch.

(avenger, would you *please* add this to the web site).

-tony

> running it at all.  All have the other http-gw patches.

---
E-Mail: Tony Gale <[email-masked]>
Harrison's Postulate:
	For every action, there is an equal and opposite criticism.

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Keith Young <[email-masked]>
Date: Fri, 07 Apr 2000 13:53:59 -0400

> (avenger, would you *please* add this to the web site).

Sorry about that... I've been busy with business travelling and
purchasing a house.

I'll have the FAQ updated (along with removing the mirror sites which
didn't apply the mirror.pl fix) tomorrow afternoon.

-- 
--Keith Young
-Director of Customer Care/Support, V-ONE Corp.
[email-masked]

---

From: Tony Gale <[email-masked]>
Date: Mon, 10 Apr 2000 09:22:33 +0100 (BST)

> didn't apply the mirror.pl fix) tomorrow afternoon.

Thanks Keith.

For patch 1.9 the error can also be Error 501

I'll try and get my other unpublished patch or two into an acceptable
state in the near future.

I personally prefer the following patch from Jean-Christophe Touvet
<[email-masked]> for the problem in 1.8:

*** hmain.c-orig        Sat Feb  7 00:32:16 1998
--- hmain.c     Wed Sep 23 17:13:42 1998
***************
*** 857,869 ****
                if(html_read(fd,(char *)&buf[x],1) != 1)
                        goto done;
  
!               /* get \r\n - read a char and throw it away */
!               if(buf[x] == '\r') {
                        if(html_read(fd,(char *)&buf[x],1) != 1)
                                goto done;
-                       buf[x] = '\0';
-                       ret = x;
-                       goto done;
                }
  
                if(buf[x] == '\n') {
--- 857,866 ----
                if(html_read(fd,(char *)&buf[x],1) != 1)
                        goto done;
  
!               /* eat all \r from the stream */
!               while(buf[x] == '\r') {
                        if(html_read(fd,(char *)&buf[x],1) != 1)
                                goto done;
                }
  
                if(buf[x] == '\n') {

---
E-Mail: Tony Gale <[email-masked]>
The only thing better than love is milk.