Subject: ftp-gw 2.1 leaves data sockets in TIME_WAIT on Solaris 2.6

From: "Mike Q. Hiller" <[email-masked]>
Date: Thu, 06 Apr 2000 15:13:15 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi,
	I have a Sun Ultra-1 running ftp-gw from TIS 2.1.
	Unfortunatly whenever I connect to it from Solaris
	FTP client (or from perl Net::FTP method), ftp data
	sockets are left on the gateway.  Anybody seen this before?

	mqh

---

From: [email-masked]
Date: Thu, 6 Apr 2000 15:49:33 -0400 (EDT)

>>>>> "Mike" == Mike Q Hiller <[email-masked]> writes:

Mike> 	I have a Sun Ultra-1 running ftp-gw from TIS 2.1.
Mike> 	Unfortunatly whenever I connect to it from Solaris
Mike> 	FTP client (or from perl Net::FTP method), ftp data
Mike> 	sockets are left on the gateway.  Anybody seen this before?

TIME_WAIT is normal. All sockets are left in TIME_WAIT after they're
closed. If you want to shorten the amount of time, use ndd to tune
tcp_close_wait_interval (or whatever it's called on your version of solaris
- I think they renamed it in 8).

-- 
Carson Gaspar -- [email-masked] [email-masked] [email-masked]
http://www.cs.columbia.edu/~carson/home.html
Queen Trapped in a Butch Body