Subject: RE: authmgr?

From: "Nixon, Anthony" <[email-masked]>
Date: Fri, 12 May 2000 09:33:24 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Thanks for help Rick, it is appreciated. Unfortunately, it seems that this
did not work either. I have tried both authmgr: authserver 127.0.0.1 7777
and authmgr: authserver localhost 7777 statements and still no joy. I have
also tried several instances of:

authsrv: permit-hosts *
authsrv: permit-hosts localhost
authsrv: permit-hosts 127.0.0.1
authsrv: hosts 127.0.0.1 and localhost, etc...

but none of them helped either. Still the same message "Can not open auth
service". What exactly is /etc/services supposed to look like concerning
both the authsrv and auth line because I have both:

authsrv	7777/tcp
auth		113/tcp  authentication tap ident

in my services file and I have changed the auth statement in inetd.conf to
point to authsrv and not in.identd. Again, authsrv works just dandy, but
authmgr does not. When I first invoke ./authmgr, the program runs (I get hd
activity). But then gives me the above message. After that, nothing, just
the same old message...

Shon

> -----Original Message-----
> From: Rick Murphy [mailto:[email-masked]]
> Sent: Thursday, May 11, 2000 10:20 PM
> To: Nixon, Anthony; [email-masked]'
> Subject: RE: authmgr?
> 
> 
> At 02:57 PM 5/11/00 -0400, Nixon, Anthony wrote:
> >[To be removed from this list send the message "unsubscribe 
> fwtk-users" in the
> >BODY of a mail message to [email-masked].]
> >
> >I have tried both adding authmgr 7777/tcp using the same 
> port number as
> >authsrv and giving it a different port (authmgr 7778/tcp) 
> but neither works.
> >Help?
> Authmgr tries to connect to the authserver using the port in 
> the netperm-table.
> You should have
> *: authserver 127.0.0.1 7777
> or equivalent in your netperm-table. Try adding
> authmgr: authserver 127.0.0.1 7777
> early on; that'll guarantee that authmgr gets the right port. 
> The authmgr 
> doesn't use anything in the services file to figure out how 
> to talk to authsrv.
>          -Rick
>

---

From: Rick Murphy <[email-masked]>
Date: Fri, 12 May 2000 11:44:53 -0400

At 09:33 AM 5/12/00 -0400, Nixon, Anthony wrote:
>and authmgr: authserver localhost 7777 statements and still no joy.

Try wildcarding it:

>  I have

Those look right (except the last one.) Really should be just 'permit-hosts 
127.0.0.1' though.

>auth            113/tcp  authentication tap ident

That's all you should need; actually 'auth' (identd) hasn't anything to do 
with it - that's a separate protocol not provided by FWTK.

How are you running authsrv? What happens when you 'telnet localhost 7777'?
         -Rick