Subject: RE: authmgr?

From: "Nixon, Anthony" <[email-masked]>
Date: Thu, 11 May 2000 14:57:58 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I have tried both adding authmgr 7777/tcp using the same port number as
authsrv and giving it a different port (authmgr 7778/tcp) but neither works.
Help?

> -----Original Message-----
> From: Ted Keller [mailto:[email-masked]]
> Sent: Wednesday, May 10, 2000 6:51 PM
> To: Nixon, Anthony
> Cc: [email-masked]'
> Subject: Re: authmgr?
> 
> 
> [To be removed from this list send the message "unsubscribe 
> fwtk-users" in the
> BODY of a mail message to [email-masked].]
> 
> Did you define authmgr in your /etc/services?
> 
> ted keller
> 
> 
> On Wed, 10 May 2000, Nixon, Anthony wrote:
> 
> > [To be removed from this list send the message "unsubscribe 
> fwtk-users" in the
> > BODY of a mail message to [email-masked].]
> > 
> > I have compiled fwtk on RH 6.1 w/ skey support. I can get 
> authsrv to run but
> > not authmgr? I add users, change authentication protocols, 
> etc in authsrv
> > without problems. But when trying to run authmgr, I keep 
> getting "Cannot
> > open auth service". I have added authsrv 7777/tcp to 
> /etc/services and
> > changed inetd.conf to read:
> > 
> > auth	stream tcp wait root /usr/local/etc/authsrv authsrv
> > 
> > 
> > netperm-table reads:
> > 
> > authsrv:	hosts	127.0.0.1
> > authsrv:	hosts	localhost  <-- tried it with and without this
> > statement
> > authsrv:	database	/usr/local/etc/authsrv.db
> > authsrv:	badsleep	259200
> > authsrv:	nobogus	true
> > 
> > *:	authserver	127.0.0.1	7777
> > 
> > Don't know what else to do? Checked netstat -a and found 
> auth waiting for
> > input but... Have recompiled and still no joy. Any help would be
> > appreciated.
> > 
> > Shon
> > 
>

---

From: Rick Murphy <[email-masked]>
Date: Thu, 11 May 2000 22:20:16 -0400

>authsrv and giving it a different port (authmgr 7778/tcp) but neither works.
Authmgr tries to connect to the authserver using the port in the netperm-table.
You should have
*: authserver 127.0.0.1 7777
or equivalent in your netperm-table. Try adding
authmgr: authserver 127.0.0.1 7777
early on; that'll guarantee that authmgr gets the right port. The authmgr 
doesn't use anything in the services file to figure out how to talk to authsrv.
         -Rick