Subject: RE: smap open relay

From: William Jackson <[email-masked]>
Date: Fri, 5 May 2000 11:35:46 +0200

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

hello there

I saw your suggestion about the yao patch

I have patched the smap.c file but when I try to complie it I get the error:

smap.o: In function `from_address_ok':
/usr/src/fwtk/fwtk/smap/smap.c:2050: undefined reference to `res_query'
/usr/src/fwtk/fwtk/smap/smap.c:2050: undefined reference to `res_query'
collect2: ld returned 1 exit status

the res_query function is included via the resolv.h header file

#include <resolv.h>

which I have in the usr/include directory with a definition of res_query

any ideas?

cheers

-----Original Message-----
From: Naresh Narang [mailto:[email-masked]]
Sent: 02 May 2000 23:59
To: [email-masked]
Cc: [email-masked]
Subject: Re: smap open relay

[To be removed from this list send the message "unsubscribe fwtk-users" in
the
BODY of a mail message to [email-masked].]

Relay must not be allowed. Install Yao Patch to stop
relay.

NKN

--- David Hamm <[email-masked]> wrote:
> [To be removed from this list send the message
> "unsubscribe fwtk-users" in the
> BODY of a mail message to [email-masked].]
> 
> I have smap and smapd running on my firewall so I
> tested it by telneting to
> mail-abuse.org and it confirmed that my firewall did
> accept relay requests. 
> Can I change this or must smap act as a relay to
> work?
> 
>  ---------------------------------
> David Hamm
> Systems Analyst
> Imaging Technologies Services Inc.
> email: [email-masked]
> voice: 404-870-6663
> ---------------------------------
> 

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Ted Keller <[email-masked]>
Date: Fri, 5 May 2000 08:46:32 -0400 (EDT)

Add -lresolv to your Makefile.  These are the resolver library routines.

ted keller