Subject: ftp-gw proxy and local ftpd access

From: "Wilfried Tresp" <[email-masked]>
Date: Sat, 20 May 2000 17:08:00 +0200

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi,

I'm can't figure out how to allow users from our internal network to connect via the ftp-gw proxy and also from some of our admin machines to connect to an ftp daemon to the same 
machine for transfering files from or to the ftp proxy.

The ftp-gw proxy is controlled from inetd. I found only one message from the unofficial TIS FWTK FAQ that says that you shouldn't use the modified ftpd from the toolkit instead you 
should use wu-ftp. I've installed wu-ftp but I unable to pass ftp requests from the proxy to in.ftpd on the same machine.

I'm running the proxy under Solaris 2.6.

Can you help me or can you point me to an document which shows how to do this?

regards,	Wilfried Tresp

---

From: Roland Krüppel <[email-masked]>
Date: Mon, 22 May 2000 18:48:50 +0200

Hi,

I don't know if this is the best (and safest) way but it seems to work ;)

In netperm-table:

# Connects from the localhost go to the wu.ftp Daemon
permit-hosts 127.0.0.1 -exec /usr/sbin/wu.ftpd
# Connects from my subnet go through the ftp-gw
netacl-wu.ftpd: permit-hosts 192.168.2.* -exec /usr/local/etc/ftp-gw
ftp-gw: permit-hosts 192.168.2.*

In inetd.conf:
# ftp Connects go through netacl
ftp	stream	tcp	nowait	root   /usr/local/etc/netacl  wu.ftpd -a

to connect to the ftp-server on this server:
open 192.168.2.1 (e.g.)
user roland@localhost

to connect to an outside ftp-server:
open 192.168.2.1
user [email-masked]

On many FTP-Clients you can specify a firewall...

regards
Roland Krüppel
Jr. System Administrator
Quirinus-Gymnasium Neuss

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Wilfried Tresp
> Sent: Saturday, May 20, 2000 5:08 PM
> To: [email-masked]
> Subject: ftp-gw proxy and local ftpd access
>
>
> I'm can't figure out how to allow users from our internal network
> to connect via the ftp-gw proxy and also from some of our admin
> machines to connect to an ftp daemon to the same
> The ftp-gw proxy is controlled from inetd. I found only one
> message from the unofficial TIS FWTK FAQ that says that you
> shouldn't use the modified ftpd from the toolkit instead you
> should use wu-ftp. I've installed wu-ftp but I unable to pass ftp
> requests from the proxy to in.ftpd on the same machine.
>