Subject: how does plug-gw work with https

From: "Yibing Li" <[email-masked]>
Date: Tue, 6 Jun 2000 16:07:26 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Dear fwtk-users,

    I am using plug-gw as a proxy for an ecredit checking.
we used to use HTTP to send request to ecredit through plug-gw and
it works well. Right now we are using https and I can DIRECTLY send
https request to ecredit and get the response back. But if I try to
pass through plug-gw, I never get it working. The following three lines
are my configurations. Are there any thing wrong with my configuration?

    someplace mentioned ssl-gw. I wonder whether that is the package
I should use instead.  Is this package also included in fwtk? I can
not find it.

    Any help is highly appreciated.

Thanks,

Yibing Li, Ph.D.
Senior Software Engineer,
Simplexity.com
703-654-4720

# plug-gw is running at 10.2.0.7 at port 8000
# ECredit rules
plug-gw:        permit-hosts 10.2.0.* -log {retr stor }

plug-gw:    port 8000 10.2.0.68 -plug-to globalfinancingnetwork.com -port
443
plug-gw:    port 443 globalfinancingnetwork.com -plug-to 10.2.0.68 -port
8000

---

From: "Yibing Li" <[email-masked]>
Date: Wed, 7 Jun 2000 16:35:03 -0400

Thanks for the help. I have got it working for sometime this morning.
But at this moment, I got the following messages:

 Jun  7 15:33:13 db-east plug-gw[1947]: cannot connect to server
/globalfinancing
network.com/443: Not owner
Jun  7 15:33:13 db-east plug-gw[1948]: cannot connect to server
/globalfinancing
network.com/443: No child processes
Jun  7 15:33:13 db-east plug-gw[1949]: cannot connect to server
/globalfinancing
network.com/443: No child processes
Jun  7 15:33:38 db-east unix: NOTICE: oracle, uid 60003: setuid execution
not al
lowed, dev=1540000

My configuration file has the following line:
plug-gw:    port 8000 10.2.0.68 -plug-to globalfinancingnetwork.com -ssl

>From above message, it looks that it can not connnect to
globalfinancingnetwork.com/443.
What can be wrong?

Thanks,

Yibing

> -----Original Message-----
> From: Yibing Li [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2000 4:07 PM
> To: [email-masked]
> Cc: David Tirtamidjaja; Joo C Chung; Yibing Li; David Mobley; Chris
> McNeilly
> Subject: how does plug-gw work with https
>
>
> Dear fwtk-users,
>