Subject: ftp-gw mkdir problem

From: Scott McEachern <[email-masked]>
Date: Tue, 06 Jun 2000 11:09:48 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

    Hi, I'm running fwtk 2.1 on OpenBSD 2.6, and everything is working
great, except one little thing:
    One of my machines ftp's to an external site and places files
there.  During the placement, it creates a directory and continues to
place files into the newly created directory.
    The problem is that when I send the "mkdir <directory" command,
I get a "500 command not understood" error.
    The machine that does the ftp has worked correctly for months, and
this problem has only occurred since I put this machine behind the
firewall.
    My netperm entry for this is:

ftp-gw: permit-hosts 192.168.0.55 -log { retr stor dele mkd syst pasv }
-plug-to <external machine IP>

    I have applied the gate-ftp patch, the fix for extended ftp
permissions, and the patch for plug capability.  Can anyone help?  TIA.

--
R. Scott McEachern, Network Administrator
J&A Media Services, Inc.,
300 John St., Suite 500
Thornhill, ON, CA.  L3T 5W4
tel: 905-881-6902  fax: 905-881-6945

---

From: Ted Keller <[email-masked]>
Date: Tue, 6 Jun 2000 12:18:57 -0400 (EDT)

Scott,

I suspect you are running a W/9x client...  If so, the client sends a new
commad to the firewall that the ftp-gw proxy does not understand. 

The attached patch (you might have to fix this up since the tabs will be
lost) should fix the problem.  It adds support for the windows command.

ted keller

*** ftp-gw.c.dist	Mon Oct 25 20:43:51 1999
--- ftp-gw.c	Mon Oct 25 20:43:16 1999
***************
*** 137,142 ****
--- 137,143 ----
  	"rest",		OP_CONN,			0,
  	"rmd",		OP_CONN|OP_XTND,		0,
  	"mkd",		OP_CONN|OP_XTND,		0,
+ 	"xmkd",		OP_CONN|OP_XTND,		0,
  	"syst",		OP_CONN,			0,
  	"acct",		OP_CONN,			0,
  	"quit",		OP_AOK,				cmd_quit,