Subject: Re: trouble with the compilation/linking of authsrv

From: [email-masked]
Date: Fri, 2 Jun 2000 13:09:13 +0100

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

This may be your problem.

Within Makefile.config in the source tree:

# Some versions of Linux have broken the crypt() function out into a
# separate library - uncomment the following line if authsrv fails to build.
AUXLIB= -lcrypt

"Piet Bos" <[email-masked]> on 02/06/2000 12:17:01

To:   [email-masked]
cc:    (bcc: Ted Rule/160GPS/Flextech/UK)

Subject:  trouble with the compilation/linking of authsrv

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I'm having trouble during the make of the pass.c source.
The error I'm getting is:

pass.o: In function `passverify':
/usr/local/fwtk/auth/pass.c:39: undefined reference to `crypt`
pass.o: In function `passset':
/usr/local/fwtk/auth/pass.c:70: undefined reference to `crypt`
collect2: ld returned 1 exit status
make: *** [authsrv] Error 1

I using gcc 2.91.66 on redhat 6.2 (Zoot) with kernel 2.2.14-5.0
The version of fwtk is 2.1 downloaded at Tis.com on May 29

Is there anyone who can help me?

cheers Pieter.
--
Pieter Bos
[email-masked]
[email-masked]
[email-masked]

---

From: "Piet Bos" <[email-masked]>
Date: Fri, 2 Jun 2000 23:43:46 +0200

Alas,
it din't do the trick, I'm still having difficulties making authsrv.
Is there something else to do, so it will work?

Piet.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: Friday, June 02, 2000 2:09 PM
To: [email-masked]
Subject: Re: trouble with the compilation/linking of authsrv

[To be removed from this list send the message "unsubscribe fwtk-users" in
the
BODY of a mail message to [email-masked].]

To:   [email-masked]

[To be removed from this list send the message "unsubscribe fwtk-users" in
the
BODY of a mail message to [email-masked].]

cheers Pieter.
--
Pieter Bos
[email-masked]
[email-masked]
[email-masked]

---

From: Rick Murphy <[email-masked]>
Date: Fri, 02 Jun 2000 23:23:21 -0400

>Is there something else to do, so it will work?

Disable password authentication - it shouldn't be used anyway.
(edit auth.h to comment out the '#define AUTHPROTO_PASSWORD' line.)
         -Rick

---

From: "Piet Bos" <[email-masked]>
Date: Mon, 5 Jun 2000 19:22:58 +0200

This sugeestion works, but isn't it a pity or rather a shame that the
feature of password authentication has to be switched of?
And why shouldn't is be used anyway, Rick?
Please elaborate.

Piet.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Rick Murphy
Sent: Saturday, June 03, 2000 5:23 AM
To: Piet Bos; [email-masked]
Subject: RE: trouble with the compilation/linking of authsrv

---

From: Rick Murphy <[email-masked]>
Date: Mon, 05 Jun 2000 17:01:24 -0400

>feature of password authentication has to be switched of?

Well, you can probably find a crypt library source somewhere.

>And why shouldn't is be used anyway, Rick?
Because password authentication is weak - anyone watching traffic to your 
firewall can capture user passwords and reuse them. All the other 
authentication protocols cannot be reused or replayed.
         -Rick