Subject: smtp problem

From: J A Shamsi <[email-masked]>
Date: Wed, 5 Jul 2000 15:01:11 -0700 (PDT)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi 
I am configuring fwtk, smap proxy  on 3.2 freebsd
machine 

I have following entries for smtp in /etc/services
 
  smtp  25/tcp   mail
  smtp  25/udp   mail

in /etc/inetd.conf smtp stream tcp nowait root 
/usr/local/libexec/smap=>smap -daemon 25 

and in /etc/rc.confsendmail_enable="NO" 
but I cannot send and recieve email form any other
hosts
I can send and recieve emails from users at the same
hosts.
i didn't recieve any error and the send and recieved 
emails from and to the  other hosts are not bounced
back .
just wondering if anyone has the idea about the
problem

thanks

jawwad

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/

---

From: Mark C Farone <[email-masked]>
Date: Thu, 6 Jul 2000 14:08:01 -0400

I'm having problems accessing certain pages through http-gw 2.1 when 
the remote server seems to require HTTP/1.1.  So far, all the servers 
happen to be running IIS.  Specifically, the pages require a HTTP/1.1 
'Host:' command.

Looking through the archives, I see that Rick had a patch for 
HTTP/1.1, but I don't see it on fwtk.org.  I'm not convinced that 
this is a problem with http-gw, but some of my users need to access 
some of these sites.

Thanks for any suggestions or pointers.

Here's an example:

>[farone@prism farone]$ telnet www.eshopflorida.com 80
>Trying 206.98.206.10...
>Connected to www.eshopflorida.com.
>Escape character is '^]'.
>GET 
>/MALL/Catalog/StoreRedir/asp/url/http%3A%2F%2Fwww%2Eaaadiscountsports%2Ecom/company_id/1000011398/name/AAA+Discount+Sports%2Ecom/mall_id/1000010557.html 
>HTTP/1.0
>
>HTTP/1.1 404 Object Not Found
>Server: Microsoft-IIS/4.0
>Date: Thu, 06 Jul 2000 17:44:01 GMT
>Content-Type: text/html
>Content-Length: 461
>[...]

It works only if you use the HTTP/1.1 'Host' command, regardless of 
whether you specify HTTP/1.0 or 1.1 (rfc2616 states it is required 
with 1.1):

>[farone@prism farone]$ telnet www.eshopflorida.com 80
>Trying 206.98.206.10...
>Connected to www.eshopflorida.com.
>Escape character is '^]'.
>GET 
>/MALL/Catalog/StoreRedir/asp/url/http%3A%2F%2Fwww%2Eaaadiscountsports%2Ecom/company_id/1000011398/name/AAA+Discount+Sports%2Ecom/mall_id/1000010557.html 
>HTTP/1.0
>Host: www.eshopflorida.com
>
>HTTP/1.1 200 OK
>Server: Microsoft-IIS/4.0
>Date: Thu, 06 Jul 2000 17:44:27 GMT
>Content-Type: text/html
>Cache-control: private

Regards,
Mark
-- 
Mark C. Farone <[email-masked]>   In the future,
Systems Analyst, Gainesville Sun        everything will work.

---

From: Ted Keller <[email-masked]>
Date: Thu, 6 Jul 2000 17:46:40 -0400 (EDT)

Mark,

Don't know if this is related....  I've seen a number of IIS type sites
that do NOT send the final <fin> on a connection (EOF) which then
terminates the read.  I've done a lot of work with the Apache proxy server
in this regard and had to change it's behaviour such that ...

1. - unbuffer any read requests comming from the remote servers
2. - pass all data received on an individual read directly to the client -
do NOT try to re-buffer the data for improved network performance.
3. - keep timeouts "small" to that these connections eventually time out.

What I observe - with these modifications - is that 

1. the client starts to behave normally - ie - it looks like it is working
2. I have a lot of hanging connections to that server until timeout
processes terminate these connections.

You may be seeing the same type of activity through http-gw.
I noted in my testing (I put up a quick http-gw server) that http-gw and
apache experienced the same issues. I've patched apache - but didn't make
corresponding patches to http-gw since I do not use that in my production
environment.

Hope this helps

ted keller

---

From: Tony Gale <[email-masked]>
Date: Fri, 07 Jul 2000 08:43:11 +0100 (BST)

On 06-Jul-2000 Ted Keller wrote:
> terminates the read.

Could you point me a site (or 2) that does that.

-tony

---
E-Mail: Tony Gale <[email-masked]>
I just forgot my whole philosophy of life!!!

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Rick Murphy <[email-masked]>
Date: Thu, 06 Jul 2000 18:57:07 -0400

At 02:08 PM 7/6/00 -0400, Mark C Farone wrote:
  >I'm having problems accessing certain pages through http-gw 2.1 when the 
  >remote server seems to require HTTP/1.1.  So far, all the servers happen 
  >to be running IIS.  Specifically, the pages require a HTTP/1.1 'Host:' command.

The "Host" header is added by the browser. If your browser generates one, 
http-gw isn't going to strip it.
The http-gw doesn't support http/1.1 - chunked pages, for example. That's 
one of the reasons the Windows Update page doesn't work through http-gw; if 
you disable http 1.1 it works fine.

           -Rick

---

From: Mark C Farone <[email-masked]>
Date: Fri, 7 Jul 2000 16:29:31 -0400

At 6:57 PM -0400 7/6/00, Rick Murphy wrote:
>The "Host" header is added by the browser. If your browser generates 
>one, http-gw isn't going to strip it.

Looking a little closer with snoop shows this to be the case--so it 
probably doesn't relate to the Host command.

>The http-gw doesn't support http/1.1 - chunked pages, for example. 
>That's one of the reasons the Windows Update page doesn't work 
>through http-gw; if you disable http 1.1 it works fine.

If I go direct (not through http-gw) and specify http/1.0, as I would 
expect, I don't seem to be getting chunked data from the IIS server. 
At least it isn't shown as a 1.1 Transfer-Encoding parameter and I 
get back the correct data:

>http://www.eshopflorida.com/MALL/Catalog/StoreRedir/asp/url/http%3A%2F%2Fwww%2Eaaadiscountsports%2Ecom/company_id/1000011398/name/AAA+Discount+Sports%2Ecom/mall_id/1000010557.html 
>HTTP/1.0
>Date: Fri, 07 Jul 2000 14:45:11 GMT
>Content-Type: text/html
>Cache-control: private
>
><html>
><head>
><title>AAA Discount Sports.com</title>
></head>
><frameset rows="*, 30" border=0>
><frame 
>src="http://www.pointshop.com/MALL/Catalog/Redir1/asp/url/http%3A%2F%2Fwww%2Eaaadiscountsports%2Ecom/name/AAA+Discount+Sports%2Ecom/company_id/1000011398/mall_id/1000010557">
><frame src="/back_to_mall.html" scrolling=no>
></frameset>
></html>Connection closed by foreign host.

Using http-gw (hence http/1.0), I get back some data, but I don't get 
what I'd expect (note the URL difference in the frame src as compared 
to above):

>[farone@halley farone]$ telnet proxy1.gvillesun.com 8888
>Trying 205.152.75.11...
>Connected to galileo.gvillesun.com.
>http://www.eshopflorida.com/MALL/Catalog/StoreRedir/asp/url/http%3A%2F%2Fwww%2Eaaadiscountsports%2Ecom/company_id/1000011398/name/AAA+Discount+Sports%2Ecom/mall_id/1000010557.html 
>HTTP/1.0
>Date: Fri, 07 Jul 2000 20:17:58 GMT
>Content-Type: text/html
>Cache-control: private
>
>
><html>
><head>
><title></title>
></head>
><frameset rows="*, 30" border=0>
><frame 
>src="http://www.pointshop.com/MALL/Catalog/Redir1/asp/url/http%3A%2F%2Fwww/name//company_id//mall_id/">
><frame src="/back_to_mall.html" scrolling=no>
></frameset>
></html>Connection closed by foreign host.

If I go direct and ask for http/1.1 I clearly receive chunked data.

It seems unlikely, but I'll check the code to see if http-gw could be 
filtering the content of the URL inside the returned HTML file??

Are there any useable http/1.1 patches (or any parts thereof) for http-gw?

TIA again,
Mark

---

From: Joseph S D Yao <[email-masked]>
Date: Mon, 10 Jul 2000 11:10:58 -0400

http-gw does bad things to %-encoded URLs.  I believe there was a patch
on fwtk.org to remove this.  There was some exploit that this was
preventing, but Marcus didn't remember what it was when I asked him a
while ago, and I haven't figured it out either.  ;-]

-- 
Joe Yao				[email-masked] - Joseph S. D. Yao
COSPO/OSIS Computer Support					EMT-B
-----------------------------------------------------------------------
This message is not an official statement of COSPO policies.