Subject: Is it better to use squid or squid-gw to hide a webserver

From: "Hermann Reimer" <[email-masked]>
Date: Mon, 17 Jul 2000 08:52:13 +0200

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi all,

I would like to hide our webserver behind the firewall.

Is it a good idea to use squid on the firewall or is it unsecure ?

Is it a better idea to use squid-gw on the firewall and put a squid-proxy server in the the same local lan as the webserver ?

Webserver is NT, firewall is SuSE Linux with two network cards and fwtk running.

I favorite this opinion because the webserver could be managed in the local lan, without any restrictions. In an DMZ the different authors of the web ( in the local lan) could only use ftp to manage their websites, so it's not so comfortable.

thank you for any help

best regards

Hermann Reimer 
 (Leiter EDV)

---------------------------------------------------------------------------------
Stadt Deggendorf
Informations- und Kommunikationstechnik
Franz-Josef-Strauß Straße 3
D-94469 Deggendorf
Germany
Tel.:  +49 (0) 991 2960 259
Fax.: +49 (0) 991 7958
mail: [email-masked]
internet: http://www.deggendorf.de
---------------------------------------------------------------------------------

---

From: Eberhard Mattes <[email-masked]>
Date: Fri, 21 Jul 2000 01:28:05 +0200 (MET DST)

> [...]
> Is it a better idea to use squid-gw on the firewall and put a
> squid-proxy server in the the same local lan as the webserver ?

squid-gw isn't designed for proxying request from the outside to the
inside.  Use http-in instead.  Note that there will be a new
em-gw.tar.gz soon, with an important bug fix for http-in.

-- 
  Eberhard Mattes <[email-masked]>