Subject: ipbind only for http-gw

From: wen <[email-masked]>
Date: Wed, 26 Jul 2000 13:5:21 +0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

 hi:

I have patched ipbind for fwtk and try to config. but I find ipbind is only for http-gw. is it true? if  reply is yes,how to resolving problem that setup ftpserver in the DMZ? please give some advice.

thanks 

wen

---

From: Scott McEachern <[email-masked]>
Date: Wed, 26 Jul 2000 05:50:39 -0400

> I have patched ipbind for fwtk and try to config. but I find ipbind is only for http-gw. is it true? if  reply is yes,how to resolving problem that setup ftpserver in the DMZ? please give some advi…

    Ipbind is not just for http-gw, but for most of the *-gw's.  Take a look at the README that comes with ipbind, it explains what files have been changed.
    You need to create a rule that plugs the ftp-gw from one host directly to the ftp server.  You will need to patch ftp-gw for this.  I have something similar set up:

ftp-gw: permit-hosts 111.222.333.* -log { retr stor (etc) } -plug-to 192.168.0.4

This allows any hosts on the 111.222.333 network to connect to your ftp server (192.168.0.4).  This rule allows a specific machine on my internal net to hit a specific site on the Internet:

ftp -gw: permit-hosts 192.168.0.55 -log { retr stor } -plug-to 111.222.333.4

--
R. Scott McEachern, Network Administrator
J&A Media Services, Inc.
300 John St., Suite 500, Thornhill, ON, CA  L3T 5W4
tel:905-881-6902  fax:905-881-6945