Subject: Re: net_flags[4]

From: "Larry Jackson" <[email-masked]>
Date: Tue, 8 Aug 2000 11:34:19 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

From: "Mario Misic" <[email-masked]>
>
> I already saw that even others have problem with http-gw.
>
> I have http-gw V2.1 and I got this error while I am trying to access
> www.xml.com .
>
> Network error: net_flags[4] set (read)
>
> I read in FAQs that it is probably bug in http-gw software, can someone
> advice me where to find patch if it exist, I tried to find it somewhere
but
> I didn't.
> Regards!
> Mario Misic

I also see these error messages in my logs.
Any progress on fixing the problem?

---

From: Tony Gale <[email-masked]>
Date: Tue, 08 Aug 2000 17:30:58 +0100 (BST)

> Any progress on fixing the problem?

I was looking at this this morning, and frankly, it aint worth the
effort.

Basically, the code is bad at propagating error conditions, and this
message just catches this.

I did try fixing it, but you just end up chasing function return
values through the code.

So, ignore the messages, and if they bother you comment them out of
gio.c

-tony

---
E-Mail: Tony Gale <[email-masked]>
The shortest distance between any two puns is a straight line.

The views expressed above are entirely those of the writer
and do not represent the views, policy or understanding of
any other person or official body.

---

From: Mario Misic <[email-masked]>
Date: Wed, 9 Aug 2000 08:34:57 +0000

I just installed squid caching server and http-gw which support squid and that
solve my problem, very funny but it works now!

By
Mario