Subject: Re: Ftp'ing from outside to inside via Netscape

From: Göran Häggsjö <[email-masked]>
Date: Thu, 07 Sep 2000 10:01:38 +0200

There is a problem with the mapping to the right IP-adress.
You should use a internal nameserver that provides the IP-address on the DMZ as
well as internals.
When you come from the internet there is an external nameserver which resolves
the name.
(If the firewall is a fast machine it can do the nameserving also, but there can
be some traps here).

By the way, have you tried to use IP-adress ?

If that works then you know that it is the DNS-2-IP.

cheers /GoHa

Leandro Gelasi wrote:

> [To be removed from this list send the message "unsubscribe fwtk-users" in the
> BODY of a mail message to [email-masked].]
>
> I am using FWTk 2.1 and all works fine.
>
> Now I would like to set up a link on my web server that point to our
> anonymous ftp server.
>
> The anon ftp server is into the dmz and it's correctly reachable
> (from outside) using a ftp client this way :
> ftp firewall.myrealdomain.it
> user ftp@anonserver
> password [email-masked]
>
> There is an URL that permit to connect to the server from the outside?
> I tried
> ftp://ftp@anonserver:[email-masked]@firewall.myrealdomain.it
>
> following the ftp://user:[email-masked] syntax but it didn't worked.
>
> Any hints?
>
> TIA
>
> LG
>
> *********************************************************************
> Leandro Gelasi
> V year Computer Science Engineering student at Siena University
> [email-masked]
>
> Gilles Villeneuve will live forever
> *********************************************************************

---

From: Leandro Gelasi <[email-masked]>
Date: Tue, 12 Sep 2000 09:52:57 +0200 (CEST)

> (If the firewall is a fast machine it can do the nameserving also, but there can

Thank you for your posting.

I use a split-DNS nameserver, half on the firewall (external names), half
on a server in the intranet.
All works fine (at least in name resolution)
 
> By the way, have you tried to use IP-adress ?

Yes, I did.

I tried ftp://[email-masked]@firewall.myreal.domain/
	ftp://ftp@anonserver@<my real ip>/
	ftp://[email-masked]@<my real ip>/
and also the above with password integrated in the URLS.

Nothing worked!

In all the case, ftp-gw replies with "Use user@domain to connect via
gateway"

It seems that Netscape uncorrectly recognize "ftp@anonserver" as a
username, stopping at first "@" char.

I repeat, all works fine using a ftp client.

LG