Subject: smapd,smap,semdmail

From: "TJ O Connor" <[email-masked]>
Date: Fri, 1 Sep 2000 10:32:08 +0100

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi all,
      I am trying to setup smap and smapd but i keep getting an error when i
try to send mail.
      I have added
(1) smtp stream tcp nowait root /usr/local/etc/smap smap
    to inetd.conf

(2) smap, smapd:  userid uucp
    smap, smapd:  directory /var/spool/inspool
    smapd:        executable /usr/local/etc/smapd

    to the netperm-table

(3) script for starting smapd to my bootscript that starts sendmail
    if [ /usr/local/etc/smapd ] ; then
          echo " Starting sendmail proxy"
          /usr/local/etc/smapd
    fi

Does sendmail have to be shut off before i run this?
do i have an error in any of the above?

Please help me

TJ

- --                      _
T.J.O'Connor            _/ \_   2200 Cork Airport Business Park,
SysAdmin               / \_/ \  Kinsale Rd., Cork, Ireland.
Comnitel Technologies  \_/ \_/  Ph: +353 21 7305620
[email-masked]    \_/    Fax: +353 21 7305624

---

From: Joseph S D Yao <[email-masked]>
Date: Fri, 1 Sep 2000 09:10:36 -0400

> do i have an error in any of the above?

Ah!  That last says it all.

Sendmail should NOT be running in daemon [-bd] mode.  Sendmail MAY be
running in queue-only [-qNNm or -qNNh] mode.

Note that, since you have given a 'chroot' directory, everything that
smap, smapd, or sendmail need must be available in the 'chroot'ed
directory.

-- 
Joe Yao				[email-masked] - Joseph S. D. Yao
COSPO/OSIS Computer Support					EMT-B
-----------------------------------------------------------------------
This message is not an official statement of COSPO policies.