Subject: [Fwd: Problem accessing my own website]

From: Don <[email-masked]>
Date: Sat, 28 Oct 2000 10:47:17 -0400

In relation to this problem, I've noted something else.  The previous line in my log file states:
http-gw[1352]:log host=unknown/<my ip> protocol=HTTP cmd=dir dest=www.my.domain.com path=/
looking at this, I see that the PATH appears to be incorrect???  Where wouldthis be configured?

Subject: Problem accessing my own website
From: Don <[email-masked]>
To: fwtk <[email-masked]>
Date: Sat, 28 Oct 2000 10:42:43 -0400

Hello,
I am not quite certain whether this problem pertains to the fwtk but if not, I trust someone will point me to the correct news group?
I am running RedHat Linux 7.0 with all the patches and have installed FWTK 2.1.  I have two networks. External network hosts the web server and the FWTK while my internal network hosts my database application.  I allow internal users to access the internet via my external machine via the FWTK proxies.
Now my problem.  I can access all internet web sites except my own.  The message in the log file states:
http-gw[1336]: failed to connect to http server www.mydomain.com (80)
I "think" the problem is that it is trying to access via port 80 while in my /etc/services file, I've set up port 81 to be http-out.   What I can't figure out is why this happens and only for my own web site.

---

From: Ted Keller <[email-masked]>
Date: Sat, 28 Oct 2000 12:50:47 -0400 (EDT)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Don,

Just a coupld of thoughts.

First - verify that your firewall can resolve www.mydomain.com.  Second,
make sure that you have a route defined such that the firewall can contact
www.mydomain.com

ted keller

---

From: Rick Murphy <[email-masked]>
Date: Sat, 28 Oct 2000 15:00:23 -0400

>looking at this, I see that the PATH appears to be incorrect???  Where 

That looks correct to me. It's connecting to your web server and asking for 
the root directory - exactly what <http://www.my-domain.com> should do.

>http-gw[1336]: failed to connect to http server www.mydomain.com (80)

Is your web server running on port 80? Does the firewall know the correct 
IP address for that machine (internal or external depending on where it's 
connected.)

I'd try 'telnet www.mydomain.com 80' - does that connect?
         -Rick

---

From: Don <[email-masked]>
Date: Mon, 30 Oct 2000 09:16:42 -0500

When I ping any Internet address from my firewall/web server, I have success.  However, when I ping www.mydomain.com, I get "unknown host www.mydomain.com".
My /etc/resolv.conf looks like this:
domain mydomain.com
nameserver 127.0.0.1
nameserver <ISP DNS#1>
nameserver (ISP DNS#2>
any recommendations?
Ted Keller wrote:
Don,
Just a coupld of thoughts.
First - verify that your firewall can resolve www.mydomain.com.  Second,
make sure that you have a route defined such that the firewall can contact
www.mydomain.com
ted keller

---

From: Don <[email-masked]>
Date: Mon, 30 Oct 2000 11:26:46 -0500

[To be removed from this list send the message "unsubscribe fwtk-users" in the BODY of a mail message to [email-masked].] I may have solved it although it may just be a workaround.  In my
/etc/hosts file, I placed a line for my webserver as follows:
<ip address>    www.mydomain.com

Don wrote:

---

From: Ted Keller <[email-masked]>
Date: Mon, 30 Oct 2000 17:23:42 -0500 (EST)

Don,

Looks like your domain is not validating correctly.  Since   your firewall
is a valid name server, I assume it is either primary or secondary for
mydomain.com.  Try...

nslookup
nslookup> ls -d mydomain.com

it should dump out the contents of your zone file.  If it fails with an
unspecified error, then either the domain did not validate or your local
system is not a valid secondary or primary for that domain.

Let's get the DNS issue solved first.

ted keller

On Mon, 30 Oct 2000, Don wrote:

> When I ping any Internet address from my firewall/web server, I have
> success.  However, when I ping www.mydomain.com, I get "unknown host
> www.mydomain.com".
> 
>       > In relation to this problem, I've noted something else. 
>       The previous
>       > line in my log file states:
>       >
>       > http-gw[1352]:log host=unknown/<my ip> protocol=HTTP
>       cmd=dir
>       > dest=www.my.domain.com path=/
>       >
>       > looking at this, I see that the PATH appears to be
>       incorrect???  Where
>       > wouldthis be configured?
>       >
> 
> 
>