Subject: Unknown problem causing machine to hang...

From: "Neil A. Hillard" <[email-masked]>
Date: Tue, 17 Oct 2000 10:17:10 +0100 (BST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hi folks,

	sorry to bother everyone, but I'm currently having problems with
our web cache which has been working for the past 6 months and now decides
to turn up it's toes whenever it feels like it.

Our current set up is:

	RedHat Linux 6.2
	Squid 2.3.STABLE4
	http-gw from FWTK 2.1
	Netscape Directory Server 4.11

The way things work:

	Squid runs on port 3128, users have their browsers configured to
use this as their proxy.  Squid hands off authentication to the Netscape
Directory Server using the LDAP authenticator.  Squid is set up with the
http-gw (running on port 8080) as it's parent.  All http-gw requests are
handed off to the http-gw which is set up to remove Java and Active-X.

Symptoms:

	Every now and again, doesn't appear to be load related as it's
happened early in the morning and late at night as well as during the day,
the server totally hangs.  Nothing is logged to the syslog, I've enabled
kernel messages on the console and disabled screen blanking but still
nothing.  APM is disabled.  It's not a hardware problem (as first
suspected) as I've rebuilt the machine on completely different hardware,
not utilising any of the old hardware and I'm still at a complete loss for
ideas.

I was just wondering whether any of you guys had seen anything similar or
whether you've got any suggestions.  Any comments welcome, as I'm getting
hassle, and I just haven't got the foggiest.

Many thanks in advance,

				Neil.

-- 
Neil Hillard                    [email-masked]
GKN Westland Helicopters Ltd.   http://www.gkn-whl.co.uk/

Disclaimer: This message does not necessarily reflect the
            views of GKN Westland Helicopters Ltd.

---

From: "Fred LB" <[email-masked]>
Date: Wed, 18 Oct 2000 15:12:49 +0200

Hi,

I had exactly the same problem as yours. It looks like editing
/usr/src/linux/Makefile and replacing 'cc' by 'kgcc' solves the problem ...

Good luck

Fred

Frederic Le Bastard
Administrateur systeme - developpement web
Tel : 02 40 35 32 32
Fax : 02 40 12 18 74
[email-masked]
Decouvrez notre site web : http://www.strathom.com

> -----Message d'origine-----
> De : [email-masked]
> [mailto:[email-masked]]De
> la part de Neil A. Hillard
> Envoye : mercredi 18 octobre 2000 13:38
> A : Tony Gale
> Cc : [email-masked]
> Objet : RE: Unknown problem causing machine to hang...
>
>
> Tony,
> > It may be a buggy ethernet driver. 2.2.17 is the way to go.
> I'll pursue 2.2.17, but it doesn't want to compile, complaining about
> 'badly punctuated parameter list in #define' in checksum.S.
>
> I therefore tried compiling 2.2.16 and that failed the same
> way.  Anyone
> know of any bugs with compiling the kernal on RedHat 7.0 ???
>
> One thing I didn't mention was that the symptoms were happening on the
> original box (the one that was up for 6 months) and it had a Compaq
> NetFlex 3 (TI ThunderLan).  We put this down to the network card and
> swapped it out for a 3com 3c905b (or c).  The new box also
> has a 3c905.
> It may well be worth routing around for a different network
> card, then.
>
> Thanks in advance for any more help,
>
>
> 				Neil.
>
> > On 17-Oct-2000 Neil A. Hillard wrote:
> > > Tony,
> > >
> > >> What kernel are you running, and on what hardware?
> > > Right, sorry for leaving that out, here goes:
> > >
> > > first of all it was working on a Compaq Proliant 5000 (Pentium Pro
> > > 200),
> > > 128Mb RAM, running RedHat Linux 6.1 (2.2.12), this was working
> > > flawlessly
> > > since 31-March-2000 until about a month ago.
> > >
> > > Now it's running on a HP NetServer (Pentium II 266),
> 128Mb RAM, 3 x
> > > 4Gb
> > > disks, with software raid 0 running across two of them, with
> > > /usr/local/squid/cache mounted on it.  Running RedHat 6.2
> (2.2.14).
> > >
> > > I've now built the Proliant 5000 up with RedHat 7.0 (2.2.16) as a
> > > test
> > > box.  It hasn't exhibited the problem yet, but it's not under half
> > > as much
> > > load as the live box.  I've just pulled down 2.2.17 and it's
> > > compiling as
> > > I type.
> > >
> > > The weird thing about it all is it was working perfectly for 6
> > > months and
> > > then suddenly went, and we hadn't even changed anything on the box
> > > at all.
> > >
> > > Anyway, hope you can understand this and hopefully it's of some
> > > use.
> > >
> > >
> > > Many thanks in advance,
> > >
> > >
> > >                               Neil.
> > >
> > >
> > >> On 17-Oct-2000 Neil A. Hillard wrote:
> > >> > Symptoms:
> > >> >
> > >> > happened early in the morning and late at night as well as
> > >> > during
> > >> > the day,
> > >> > the server totally hangs.  Nothing is logged to the
> syslog, I've
> > >> > enabled
> > >> > not utilising any of the old hardware and I'm still at a
> > >> > complete
> > >> > loss for
> > >> > ideas.
> > >> >
> > >>
> > >> ---
> > >> E-Mail: Tony Gale <[email-masked]>
> > >> People are always available for work in the past tense.
> > >>
> > >> The views expressed above are entirely those of the writer
> > >> and do not represent the views, policy or understanding of
> > >> any other person or official body.
> > >>
> > >
> > > --
> > ---
> > E-Mail: Tony Gale <[email-masked]>
> > Fortune and love befriend the bold.
> > 		-- Ovid
> >
> > The views expressed above are entirely those of the writer
> > and do not represent the views, policy or understanding of
> > any other person or official body.
> >
>
> --

---

From: "Fred LB" <[email-masked]>
Date: Wed, 18 Oct 2000 16:38:04 +0200

Sorry for writing back, but an updated RPM of glibc, available on any good
redhat mirror, should also solve the problem.

The thing is the glibc (2.96) shipped with RH 7.0 is not yet supported by
2.2.17 kernel ... but well ... at least redhat was ready before the kernel
... can't blame them :-)

info : The trick of replacing cc by kgcc makes your stuff compiled with egcs
1.1.2 instead of glibc 2.96

Fred

Frederic Le Bastard

> la part de Fred LB
> Envoye : mercredi 18 octobre 2000 15:13
> A : 'Neil A. Hillard'
> Cc : [email-masked]
> > > >> >       Every now and again, doesn't appear to be load
> related as
> > > >> >       it's
> > > >> > kernel messages on the console and disabled screen
> blanking but
> > > >> > still
> > > >> > suspected) as I've rebuilt the machine on completely
> different
> > > >> > hardware,