Subject: smap: spam-block

From: "Ken Long" <[email-masked]>
Date: Wed, 22 Nov 2000 16:36:43 -0700

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

The archives don't have an answer to this...

I'm trying to get the spam-block option working.  I'm using smap 2.1 with the 
Yao patches (V2.1/2.1+anti-relay+anti-spam).   

I've tried two ways but email from the specified sender still gets through to 
the specified recipient.

smap: spam-block deny [email-masked] \
[email-masked]
(Shown line wrapped in this message only.)

smap: spam-block deny [email-masked] [email-masked]

Neither one of these will block.  Am I doing this correctly?

Other options in my netperm-table are

smap:	scrub-spam
smap:	check-from-address 1
smap:	broken-from <>

plus some other unrelated stuff.

TIA,
Ken Long
Lectrosonics, Inc.

---

From: Rick Murphy <[email-masked]>
Date: Wed, 22 Nov 2000 21:43:41 -0500

>Yao patches (V2.1/2.1+anti-relay+anti-spam).

Make sure you compile smap with PROTECTINBOUND defined; otherwise, 
spam-block doesn't do anything. It's not defined in the default source.

The form of the block entry is your second example:
smap: spam-block deny [email-masked] [email-masked]

I've never used 'spam-block', however, so good luck :-)
         -Rick

---

From: "Ken Long" <[email-masked]>
Date: Mon, 27 Nov 2000 08:20:29 -0700

Thanks Rick. Except for the Yao patches, I haven't modified the source at 
all. I'll check my source for PROTECTINBOUND.

Ken

---

From: "Ken Long" <[email-masked]>
Date: Mon, 27 Nov 2000 16:23:13 -0700

I added this to the Makefile

  CFLAGS= -I.. $(COPT) -DPROTECTINBOUND

but smap still isn't blocking defined addresses. They just sail on through 
like a knife through butter!

The output of the make command was:

lectro7:/usr/src/fwtk/smap# make
cc -I.. -g -DLINUX -DPROTECTINBOUND   -c smap.c -o smap.o
cc -I.. -g -DLINUX -DPROTECTINBOUND   -c arpadate.c -o arpadate.o
cc -g -static -o smap smap.o arpadate.o ../libfwall.a

I can post my entire netperm-table if necessary.

Thanks,
Ken

---

From: "Ken Long" <[email-masked]>
Date: Wed, 29 Nov 2000 09:12:36 -0600

Ok, is anyone using spam-block successfully?  I'm beginning to wonder if this 
feature is working at all.

(BTW, this list has really dropped in volume.  What's everyone using these 
days?  Netfilter?)

Ken