Subject: Re: [Fwd: Problem accessing my own website]

From: Don <[email-masked]>
Date: Thu, 02 Nov 2000 09:02:24 -0500

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello Ted,

I tried the nslookup on my domain and received the following:

==============================
> www.mydomain.com
Server:  localhost
Address:  127.0.0.1

*** localhost can't find www.mydomain.com: Non-existent host/domain
==============================

Of course, I attempted the above on outside domains with success!

So, it appears that there is a subtle problem with my DNS.  I say subtle
because:

a) requests to access my web site from the outside are successful
b) sending mail from the outside in and vice versa works fine

I don't know if this is a clue but my /etc/messages file is littered with the
following:

sysquery: findns error (NXDOMAIN) on myserver.mydomain.com?

Thanks for your assistance,
Don

Ted Keller wrote:

> Don,
>
> Looks like your domain is not validating correctly.  Since   your firewall
> is a valid name server, I assume it is either primary or secondary for
> mydomain.com.  Try...
>
> nslookup
> nslookup> ls -d mydomain.com
>
> it should dump out the contents of your zone file.  If it fails with an
> unspecified error, then either the domain did not validate or your local
> system is not a valid secondary or primary for that domain.
>
> Let's get the DNS issue solved first.
>
> ted keller
>
> On Mon, 30 Oct 2000, Don wrote:
>
> > When I ping any Internet address from my firewall/web server, I have
> > success.  However, when I ping www.mydomain.com, I get "unknown host
> > www.mydomain.com".
> >
> > My /etc/resolv.conf looks like this:
> >
> > domain mydomain.com
> > nameserver 127.0.0.1
> > nameserver <ISP DNS#1>
> > nameserver (ISP DNS#2>
> >
> > any recommendations?
> >
> > Ted Keller wrote:
> >
> >       Don,
> >
> >       Just a coupld of thoughts.
> >
> >       First - verify that your firewall can resolve
> >       www.mydomain.com.  Second,
> >       make sure that you have a route defined such that the
> >       firewall can contact
> >       www.mydomain.com
> >
> >       ted keller
> >
> >       On Sat, 28 Oct 2000, Don wrote:
> >
> >       > In relation to this problem, I've noted something else.
> >       The previous
> >       > line in my log file states:
> >       >
> >       > http-gw[1352]:log host=unknown/<my ip> protocol=HTTP
> >       cmd=dir
> >       > dest=www.my.domain.com path=/
> >       >
> >       > looking at this, I see that the PATH appears to be
> >       incorrect???  Where
> >       > wouldthis be configured?
> >       >
> >
> >
> >

---

From: Paul Dunphy <[email-masked]>
Date: Thu, 02 Nov 2000 09:33:14 -0500

Don,

Is it possible that your internal name server (127.0.0.1) is authoritative 
for mydomain.com, but does not have an entry for "www" in its db files? If 
that is the case, it will not query the ISP's DNS servers, since it is 
believes that it is authoritative for your domain; it will simply say that 
the host does not exist. Outside systems, however, probably query the ISP 
DNS servers first, which are able to resolve the address.

A similar thing happened to me recently when I set up split DNS - it seems 
I forgot to put an entry for www on the internal DNS server, so machines on 
the outside could resolve it (using the external DNS server), but those on 
the inside couldn't.

Hope this helps,
Paul

>I tried the nslookup on my domain and received the following:

---------------------------------------------------------------------
Paul T. Dunphy, P.Eng.
Systems Administrator/Research Engineer
Centre for the Study of Commercial Activity
Ryerson Polytechnic University
Toronto, Ontario, CANADA
Phone: (416) 979-5000 ext. 7537
Fax: (416) 979-5378
E-mail: [email-masked]