Subject: Re: Problem using nntp-gw

From: Naresh Narang <[email-masked]>
Date: Fri, 1 Dec 2000 10:31:47 -0800 (PST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I used plug-gw with auth for this.

NKN
--- Olivier Hislaire <[email-masked]> wrote:
 > [To be removed from this list send the message
 > "unsubscribe fwtk-users" in the
 > BODY of a mail message to [email-masked].]
 > 
 > Hi,
 > 
 > I added the nntp-gw subdirectory to the fwtk tree,
 > compiled and installed 
 > it without any trouble. The trouble starts when I
 > try to use it:
 > 
 > Dec 1 12:42:34 skimmer nntp-gw[951]: Starting daemon
 > mode on port 119
 > Dec 1 12:42:59 skimmer kernel: SCSLog: connect -
 > Name: nntp-gw | UID: 9 | 
 > EUID: 9 | PID: 956 | IP: 195.72.74.1 | Port: 53
 > Dec 1 12:42:59 skimmer kernel: SCSLog: connect -
 > Name: nntp-gw | UID: 9 | 
 > EUID: 9 | PID: 956 | IP: 195.72.74.1 | Port: 53
 > Dec 1 12:42:59 skimmer nntp-gw[956]: permit 
 > host=charlie.be.msg-i.com/192.168.32.194 use of
 > gateway
 > Dec 1 12:43:00 skimmer nntp-gw[956]: command: MODE
 > READER
 > Dec 1 12:43:00 skimmer nntp-gw[956]: Assertion
 > failed: f != NULL, file 
 > emo.c, line 176
 > 
 > Would anybody know about what it means ? accordingly
 > to fwtk/libem/emo.c, 
 > 'f' seems to be a file descriptor, may be the
 > connection to the server 
 > Since, I've checked that the server was available
 > (telnet on port 119).
 > 
 > Any idea or advice appreciated.
 > 
 > Olivier.
 >
------------------------------------------------------------------------------------------------
 > Olivier Hislaire
 > 
 > MSG International                   Email:  
 > [email-masked]
 > 97 Avenue de Tervuren             Phone: +32 (0)2
 > 735.91.59 Ext. 55
 > 1040 Brussels                         Fax:     +32
 > (0)2 732.12.19
 > Belgium                                 
 > http://www.msg-i.com
 >
------------------------------------------------------------------------------------------------

=====
-- Naresh

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: Eberhard Mattes <[email-masked]>
Date: Mon, 11 Dec 2000 22:40:52 +0100 (MET)

> It is version 0.5 :-((

Are you sure that the *running* nntp-gw is version 0.5?

> It looks like the nntp-gw program expects to be already connected to the 
> server when it receives the 'MODE READER' command from the client.

Yes.  If it is not connected to the server, version 0.5 will respond with

  450 Authorization required for this command

> Since I do not have the SERVER directive in the configuration file
> (using more than one news server), nntp-gw cannot connect immediately
> to the server; instead, it waits for the AUTHINFO USER command to
> retrieve the server name and connect.

You might want to run multiple copies of nntp-gw on different ports.

-- 
  Eberhard Mattes <[email-masked]>