Subject: Re: smap: spam-block

From: "Ken Long" <[email-masked]>
Date: Fri, 1 Dec 2000 14:43:20 -0700

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Spam-block is working here now.  Here's what was done to fix it.

1. PROTECTINBOUND had to be defined in the make file and smap recompiled.

3. Need wildcards before and after:
    smap:		spam-block deny [email-masked]* [email-masked]*

There is something about brackets <> around the address that comes into play 
here.  I was tipped off to this when I used telnet to test it and was 
properly blocked when I forgot to enclose the MAIL FROM: address in brackets 
but allowed when I used them.  The fix was to wildcard everything.

Ken Long
[email-masked]
Lectrosonics, Inc.
Rio Rancho, NM - USA

On 29 Nov 2000, at 9:12, Ken Long wrote:

> Ok, is anyone using spam-block successfully?  I'm beginning to wonder if this 
> feature is working at all.

---

From: Ted Keller <[email-masked]>
Date: Sat, 2 Dec 2000 13:39:04 -0500 (EST)

Ken,

I've developed independently a version of spam blocking that parrallels
they Yao patches.  It is not the same - but it does work.

It, in addition, also has content spam checking and blocks accordingly.
The code now looks in the message headers for matches agains the from, to,
subject lines as well as the first 10 lines of the message text.  If you
desire, I can make this availble to you.

ted keller

On Wed, 29 Nov 2000, Ken Long wrote:

> (BTW, this list has really dropped in volume.  What's everyone using these 
> days?  Netfilter?)
> 
> Ken
> 
> On 27 Nov 00, at 16:23, Ken Long wrote:
> 
> > I added this to the Makefile
> > 
> >   CFLAGS= -I.. $(COPT) -DPROTECTINBOUND
> > 
> > but smap still isn't blocking defined addresses. They just sail on through 
> > like a knife through butter!
> > 
> > The output of the make command was:
> > 
> > lectro7:/usr/src/fwtk/smap# make
> > cc -I.. -g -DLINUX -DPROTECTINBOUND   -c smap.c -o smap.o
> > cc -I.. -g -DLINUX -DPROTECTINBOUND   -c arpadate.c -o arpadate.o
> > cc -g -static -o smap smap.o arpadate.o ../libfwall.a
> > 
> > I can post my entire netperm-table if necessary.
> > 
> > Thanks,
> > Ken
> > 
> > On 22 Nov 2000, at 21:43, Rick Murphy wrote:
> > 
> > > At 04:36 PM 11/22/00 -0700, Ken Long wrote:
> > > >I'm trying to get the spam-block option working.  I'm using smap 2.1 with the
> > > >Yao patches (V2.1/2.1+anti-relay+anti-spam).
> > > 
> > > Make sure you compile smap with PROTECTINBOUND defined; otherwise, 
> > > spam-block doesn't do anything. It's not defined in the default source.
> > > 
> > > The form of the block entry is your second example:
> > > smap: spam-block deny [email-masked] [email-masked]
> > > 
> > > I've never used 'spam-block', however, so good luck :-)
> > >          -Rick
>