Subject: Ftp throug http-gw (HELP!!!)

From: Zakharov Mikhail <[email-masked]>
Date: Wed, 31 Jan 2001 08:07:07 -0800 (PST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello! Help!
I have troubles with http-gw. I'm going to use it for
ftp-connections. It does not work. Ports in browser
are correct (the ftp-proxy==http-proxy). Html-page
shows: "FTP Error 215" or "FTP Error 200". It tries to
run commands "system" & "binary". Unix-box - i386
under FreeBSD 4.1. 

Here is my inetd.conf:
#-----------------------------------------------
ftp     stream  tcp     nowait  root
/usr/local/libexec/ftp-gw       ftp-gw

gopher  stream  tcp     nowait  root   
/usr/local/libexec/http-gw      http-gw

http    stream  tcp     nowait  root   
/usr/local/libexec/http-gw      http-gw

authsrv stream  tcp     nowait  root   
/usr/local/libexec/authsrv      authsrv

#----------------------------------------
here is my netperm-table:

netacl-ftp: permit-hosts * -exec
/usr/local/libexec/ftp-gw

ftp-gw:  directory /home/zmey
ftp-gw:  timeout 1800
ftp-gw:  permit-hosts * -log { retr stor }

http-gw: userid 1000
http-gw: directory /home/www
http-gw: permit-hosts * -log { read write ftp }
http-gw: ftp-proxy 127.0.0.1
http-gw: timeout 1800 192.168.45.14

authsrv:        hosts *
authsrv:        permit-hosts *
authsrv:        database /usr/local/etc/fw-authdb
authsrv:        badsleep 1200
authsrv:        nobogus true

*:              authserver 127.0.0.1 7777
#---------------------------------------------
Best regards
Mikhail

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: Ted Keller <[email-masked]>
Date: Wed, 31 Jan 2001 12:03:31 -0500 (EST)

Mikhail,

In your browser, set the http proxy and ftp proxy to your firewall on port
80 - both of them.

In you netperm table - remove the http-gw line

See if it works.

tek