Subject: smap anti-relaying - outward-bound mail rejected

From: [email-masked] (Derek Torrance)
Date: Thu, 25 Jan 2001 15:15:17 +0000

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

     We have a working smap/sendmail configuration to which I have applied 
     the yao-smap patch. This has stopped messages from being relayed and 
     incoming messages are ok but outward-bound messages from valid domains 
     are also being rejected:
     
        220 corpinter1 SMTP/smap Ready.
        helo corpinter1
        250 (corpinter1) pleased to meet you.
        mail from:[email-masked]
        250 [email-masked]... Sender Ok
        rcpt to:[email-masked]
        551 Recipient must be in the local domain(s).
        501 Mail not local. Closing connection.
     
     I've spent the last few hours going through the mailing list archives 
     and others with this problem have been advised to make entries in the 
     netperm-table like these:
     
        smap: domains quanta.co.nz *.quanta.co.nz
        smap: hosts quanta.co.nz *.quanta.co.nz
     
     But that's pretty much what I was using:
     
        # mail access
        smap, smapd:            userid mail
        smap, smapd:            directory /var/spool/smap
        smapd:                  executable /usr/local/etc/smapd
        smapd:                  sendmail /usr/local/etc/sendmail-save
        smapd:                  baddir /var/spool/smap/undelivered
        smap:                   timeout 3600
        smap:                   domains glasgow.gov.uk *.glasgow.gov.uk
        smap:                   hosts glasgow.gov.uk *.glasgow.gov.uk
     
     My guess is I've missed something pretty basic somewhere but I'm 
     tearing my hair out trying to figure out what. Does anyone have any 
     ideas?
     
     Thanks,
     Derek

---

From: [email-masked] (Derek Torrance)
Date: Mon, 29 Jan 2001 16:28:14 +0000

I have my problems with this sorted. You can all stop worrying and 
     sleep easy tonight. :)
     Thanks to Jan and Kemal for their suggestions. The problem was mainly 
     due to the way I was testing rather than my config.
     
     derek