Subject: ftp-gw

From: Scott McEachern <[email-masked]>
Date: Tue, 13 Feb 2001 09:00:09 -0500

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

    I'm curious to know if the ftp-gw uses anything ``non-standard''
to create directories?
    My problem is that I have a client that is using WFTPD 2.30 (by
Texas Imperial Software) and when an automated process I have tries to
create a directory on their end, I get a 500 error.  I have the script
output to a text file, and it simply reads:

mkdir 010213              #(today's date, for today's delivery)
500 command not understood

    and I'm trying to figure out what's going on.  As a result of
this, I manually ftp to their site once a month and create the daily
directories by hand, and I'd really like to not do that! ;-)
    Any thoughts/experience in this matter?  TIA!

--
R. Scott McEachern, Network Administrator
J&A Media Services, Inc.
300 John St., Suite 500, Thornhill, ON, CA  L3T 5W4
tel:905-881-6902  fax:905-881-6945

---

From: Ted Keller <[email-masked]>
Date: Tue, 13 Feb 2001 21:53:10 -0500 (EST)

Scott,

I had to add the following command to make windows clients work.... maybe
this will fix your also.

ted keller

*** ftp-gw.c.dist	Mon Oct 25 20:43:51 1999
--- ftp-gw.c	Mon Oct 25 20:43:16 1999
***************
*** 137,142 ****
--- 137,143 ----
  	"rest",		OP_CONN,			0,
  	"rmd",		OP_CONN|OP_XTND,		0,
  	"mkd",		OP_CONN|OP_XTND,		0,
+ 	"xmkd",		OP_CONN|OP_XTND,		0,
  	"syst",		OP_CONN,			0,
  	"acct",		OP_CONN,			0,
  	"quit",		OP_AOK,				cmd_quit,

---

From: Rick Murphy <[email-masked]>
Date: Tue, 13 Feb 2001 20:15:11 -0500

>     I'm curious to know if the ftp-gw uses anything ``non-standard''

No, it just passes the client command to the server.

 >output to a text file, and it simply reads:

If the client is using XMKD, you can add it to the command table in ftp-gw.
Just duplicate the
          "mkd", OP_CONN|OP_XTND, 0,
line and change "mxd" to "xmkd".
          -Rick