Subject: FTP proxy problem with one location and was wondering

From: "Skolnik, Ed" <[email-masked]>
Date: Tue, 20 Feb 2001 14:26:10 -0600

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I seem to be having a FTP proxy problem with one location and was wondering
if anyone out there could maybe point me in the right direction?
It seems like I am seeing either "CNTRL-M's or CNTRL-H's" where the password
should be.

Script command is started on Tue Feb 20 14:10:40 CST 2001.
# ./eis.ksh
+ id -u
+ ((  0 == 0  ))
+ + hostname
PS1=flrprdd# 
+ set -o vi
+ date
+ echo Starting ./eis.ksh Tue Feb 20 14:10:45 CST 2001
Starting ./eis.ksh Tue Feb 20 14:10:45 CST 2001
+ + basename ./eis.ksh
tmpfile=/tmp/eis.ksh.33516
+ echo open firewall\nuser [email-masked] xxxxx\nprompt\ndir \nbye\n
+ tee /tmp/eis.ksh.33516
+ ftp -v -n
+ 2>& 1
Connected to gateway.
220 gw.florsheim.com FTP proxy (Version V2.0) ready.
----GATEWAY CONNECTED TO ftp.scudder.com----
Invalid reply.
220 FTP server ready.
Login failed.
Interactive mode off.
USER 062677
Invalid reply.
530 Peer has closed connection
500 must be connected to remote server
+ cat /tmp/eis.ksh.33516
Connected to gateway.
220 gw.florsheim.com FTP proxy (Version V2.0) ready.
----GATEWAY CONNECTED TO ftp.scudder.com----
Invalid reply.
220 FTP server ready.
Login failed.
Interactive mode off.
USER 062677
Invalid reply.
530 Peer has closed connection
500 must be connected to remote server
+ ls -l /tmp/eis.ksh.33516
-rw-r--r--   1 root     system       292 Feb 20 14:10 /tmp/eis.ksh.33516

+ vi /tmp/eis.ksh.33516
[?7h[?1l(B=[24;1H[?25h="/tmp/eis.ksh.33516" 11 lines, 292 characters
[H[2JConnected to gateway.[H
220 gw.florsheim.com FTP proxy (Version V2.0) ready.
----GATEWAY CONNECTED TO ftp.scudder.com----^M
Invalid reply.
220 FTP server ready.
Login failed.
Interactive mode off.
USER 062677^M
Invalid reply.
530 Peer has closed connection
500 must be connected to remote server
[J[?25h>[?7h[?7h[?1l(B=[24;1H[J[?25h+ exit
flrprdd# 

Script command is complete on Tue Feb 20 14:11:11 CST 2001.

Ed Skolnik 
Florsheim Group Inc. 
MIT Consultants 
200 N. LaSalle 
Chicago IL. 60601 
312-458-2655 Phone 
312-458-2661 Fax 
[email-masked] 

Confidentiality Notice: This e-mail message, including any attachments, is
for the sole use of the intended recipient(s) and may contain confidential
and privileged information. Any unauthorized review, use, disclosure or
distribution is prohibited. If you are not the intended recipient, please
contact the sender by reply e-mail and destroy all copies of the original
message. Thank you.

---

From: Rick Murphy <[email-masked]>
Date: Tue, 20 Feb 2001 21:12:04 -0500

>It seems like I am seeing either "CNTRL-M's or CNTRL-H's" where the password

You're trying to use "echo" to feed a set of commands to your ftp client 
with newline separators; are you sure that client's going to work that way? 
I'd start out with trying the same commands interactively - if they work 
through the ftp-gw then you've eliminated it as the cause.
          -Rick