Subject: Trouble in SMAP/SMAPD

From: "Sajeev" <[email-masked]>
Date: Thu, 1 Feb 2001 11:22:48 +0530

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

HI.
I have set up a firewall with fwtk. My internal network is on a Private Ip.
Is theer any special set up that I should do for the http-gw to work. I have
made all the necessary entries in my netperm table for both smap and
http-gw. But both are not working.
Is it necessary for me to have sendmail accepting requests on the firewall
machine for smap to be running.

A snap shot of my netperm table is as follows.

smap, smapd:	userid 6
smap, smapd:	directory /u2/spool/smap
smapd:		executable /usr/local/etc/smapd
smapd:		sendmail /usr/sbin/sendmail
smap:		timeout 3600

http-gw:	timeout 1800
http-gw:	permit-hosts	10.50.50.*
http-gw:	deny-hosts unknown

ftp-gw:	denial-msg	/usr/local/etc/ftp-deny.txt
ftp-gw:	welcome-msg	/usr/local/etc/ftp-welcome.txt
ftp-gw:	help-msg	/usr/local/etc/ftp-help.txt
ftp-gw:		timeout 3600

tn-gw:		timeout 3600
tn-gw:		permit-hosts YOURNET.* -passok -xok

rlogin-gw:	timeout 3600
rlogin-gw:	permit-hosts YOURNET.* -passok -xok

authsrv:	hosts 127.0.0.1
authsrv:	database /usr/local/etc/fw-authdb
authsrv:	badsleep 1200
authsrv:	nobogus true

# clients using the auth server
*:		authserver 127.0.0.1 7777

# X-forwarder rules
tn-gw, rlogin-gw:	xforwarder /usr/local/etc/x-gw

Thanks in advance...

Sajeev

---

From: Jan Muenther <[email-masked]>
Date: Thu, 01 Feb 2001 10:54:43 +0000

> http-gw. But both are not working.

I'd be interested in HOW exactly you are running the daemons,
from inetd or standalone...? If from inetd, I'd like to see your
inetd.conf, if standalone, make sure they're running.

> machine for smap to be running.

Definitely not. The only one listening on port 25 should be smap.
It uses sendmail to hand on the received mail, but that's a
different thing. 

-- 
Radio HUNDERT,6 Medien GmbH Berlin
- EDV -
[email-masked]

---

From: "Sajeev" <[email-masked]>
Date: Fri, 2 Feb 2001 17:35:14 +0530

Hi.

I am not able to push my mails through the firewall. My configurations are
as follows.

smap and smapd are running as daemons
plug-gw is being started thru inetd

my mail client is MS Outlook. The settings on the client are as follows
 1. outgoing pop3 server is the firewall machine
 2. outgoing smtp server is also the firewall machine
 3. the connecting port is the default pop3 and smtp ports
The mail server is located outside the network with our ISP.
Thanks in advance
Can anyone out there be of any help .....
Sajeev

-