Subject: Re: help!!!

From: Douglas Bowerman <[email-masked]>
Date: Thu, 15 Feb 2001 18:23:13 GMT

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello,
In error.c this is at your line -> 

int gostarterror(sockfd, errorno)
int sockfd;
int errorno;
{

Well, you should change the code to ->
int gostarterror(int sockfd, int errorno)
{

All of the occurrences of parameters sent to functions have this problem 
with the C compiler.

>>>>>>>>>>>>>>>>>> Original Message <<<<<<<<<<<<<<<<<<

On 02/15/2001, 1:11:56 AM, [email-masked] wrote regarding help!!!:

>     make[1]:Entering directory '/root/fwtk/fwtk/http-gw'
>     cc -I..-g -DLINUX  -c -o error.o error.c
>     error.c:126: parse error before '('
>     error.c:133: parse error before string constant
>     error.c:134: warning:parameter names (without types) in function 
declaration
>     error.c:135: parse error before string constant
>     ....

---

From: Rick Murphy <[email-masked]>
Date: Thu, 15 Feb 2001 21:18:44 -0500

>All of the occurrences of parameters sent to functions have this problem

Your compiler isn't accepting K&R "C"; try compiling with "-traditional" on 
the command line.
          -Rick