Subject: RE: plug-gw and samba

From: "Michael St. Laurent" <[email-masked]>
Date: Wed, 21 Feb 2001 10:29:57 -0800

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Part of the problem is that netbios-ns is a UDP service not TCP.  Plug-gw
will only work for TCP services.  You must use another program such as
Udprelay for UDP services.

--------------------
Michael St. Laurent
Hartwell Corporation

> -----Original Message-----
> From: Michel Bardiaux [mailto:[email-masked]]
> Sent: Wednesday, February 21, 2001 8:28 AM
> To: [email-masked]
> Subject: Re: plug-gw and samba
> 
> 
> [To be removed from this list send the message "unsubscribe 
> fwtk-users" in the
> BODY of a mail message to [email-masked].]
> 
> [email-masked] wrote:
>  > 
>  > I want make two plug to server1 and server2 samba.
>  > 
>  > I have into netperm-table this config :
>  > 
>  > plug-gw: port netbios-ns 1.2.3.* -plug-to server1 -port netbios-ns
>  > plug-gw: port netbios-ssn 1.2.3.* -plug-to server1 -port 
> netbios-ssn
>  > 
>  > and into my rc.local, I have :
>  > 
>  > [...]/plug-gw -daemon 137 netbios-ns &
>  > [...]/plug-gw -daemon 139 netbios-ssn &
>  > 
>  > How make for append an other plug (samba) to server2 ?
>  > 
>  > Regards.
> 
> Untried WAG: use a relayer.
> 
> On *another* machine, say 1.2.3.1, which is not itself a 'true' Samba
> server, run plug-gw like this:
> 
> in /etc/services: netbios-alt-ns 9137
> 
> in netperm-table:
> 
> plug-gw: port netbios-ns 1.2.3.* -plug-to firewall -port 
> netbios-alt-ns
> 
> in rc.local
> 
> plug-gw -daemon 137 netbios-ns
> 
> On the firewall:
> 
> in /etc/services: netbios-alt-ns 9137
> 
> in netperm-table:
> 
> plug-gw: port netbios-alt-ns 1.2.3.1 -plug-to server2 -port netbios-ns
> plug-gw: port netbios-ns 1.2.3.* -plug-to server1 -port netbios-ns
> 
> in rc.local
> 
> plug-gw -daemon 137 netbios-ns
> plug-gw -daemon 9137 netbios-alt-ns
> 
> As I said, this is a wild-assed guess. If I'm wrong, someone 
> please tell
> me!
> 
> -- 
> Michel Bardiaux
>

---

From: Michel Bardiaux <[email-masked]>
Date: Thu, 22 Feb 2001 10:45:24 +0100

> Udprelay for UDP services.

Quite right, I confused NS and SSN! As a matter of fact, the plug for
netbios-ns was actually useless in the OP's config as well. Fortunately,
one does not *need* netbios-ns to connect to a *known* samba drive, only
to "browse network neighborhood". Correction for my proposed config
follows:

On the relayer, say 1.2.3.1, which is not itself a 'true' Samba
server, run plug-gw like this:

in /etc/services: netbios-alt-ssn 9139

in netperm-table:
plug-gw: port netbios-ssn 1.2.3.* -plug-to firewall -port
netbios-alt-ssn

in rc.local

plug-gw -daemon 139 netbios-ssn

On the firewall:

in /etc/services: netbios-alt-ssn 9139

in netperm-table:

plug-gw: port netbios-alt-ssn 1.2.3.1 -plug-to server2 -port netbios-ssn
plug-gw: port netbios-ssn 1.2.3.* -plug-to server1 -port netbios-ssn

in rc.local

plug-gw -daemon 139 netbios-ssn
plug-gw -daemon 9139 netbios-alt-ssn

That should take care of the NETBIOS-SSN service. For NETBIOS-NS, as you
said, udprelay will be needed, even for 1 server. For two, I think the
same relaying strategy might be required.

Comments?

-- 
Michel Bardiaux
Peaktime Belgium S.A.  Rue Margot, 37  B-1457 Nil St Vincent
Tel : +32 10 65.44.15  Fax : +32 10 65.44.10