Subject: SMAP Patch

From: "Hodges, Michael" <[email-masked]>
Date: Fri, 2 Feb 2001 10:12:15 -0500

I'm trying to apply the yao smap patch.  The patch goes through fine, but
when I try to make the file I get the following output.  Where do I rectify
the undefined reference?  TIA

------------------------------------
# make smap
cc -I.. -g -DLINUX   -c smap.c -o smap.o
cc -g -static -o smap smap.o arpadate.o ../libfwall.a -lcrypt
smap.o: In function `from_address_ok':
/apps/src/fwtk/smap/smap.c:2015: undefined reference to `res_query'
/apps/src/fwtk/smap/smap.c:2015: undefined reference to `res_query'
collect2: ld returned 1 exit status
make: *** [smap] Error 1

------------------------------------
Michael J. Hodges
Computer Systems Coordinator
The Episcopal Diocese of Massachusetts
138 Tremont Street
Boston, MA  02111-1319
------------------------------------
Phone: (617) 879-6300
Fax:     (617) 482-8431
email:   [email-masked]
Web:    http://www.diomass.org

---

From: Ted Keller <[email-masked]>
Date: Fri, 2 Feb 2001 11:21:51 -0500 (EST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Add -lresolv to your make file.  These are the resolver libraries which
smap used to validate sending domain.

ted keller

---

From: Michel Bardiaux <[email-masked]>
Date: Fri, 02 Feb 2001 17:16:50 +0100

> "Hodges, Michael" wrote:
> 
> I'm trying to apply the yao smap patch.  The patch goes through fine,
> but when I try to make the file I get the following output.  Where do
> I rectify the undefined reference?  TIA
> 

nm -D -o /lib/li*.so.* | fgrep res_q

reveals the horrible truth: with libc5 the resolver stuff was inside
libc; starting with libc6 you need -lresolv

Did someone say "DLL hell"?

Greetings.
-- 
Michel Bardiaux
Peaktime Belgium S.A.  Rue Margot, 37  B-1457 Nil St Vincent
Tel : +32 10 65.44.15  Fax : +32 10 65.44.10