Subject: How to build fwtk under Redhat 7.0

From: [email-masked]
Date: Fri, 16 Feb 2001 18:18:29 +0800 (CST)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

dear all:
   I'm a new to fwtk and linux,when I build fwtk under Redhat,
so many errors come to me and i don't know how to do with it,
the error are listed below:

make[1]:Entering directory '/root/fwtk/fwtk/auth'
cc -g -static -o authsrv authsrv.o proto.o db.o pass.o sevio.o   ..libauth.a
pass.o:In function 'passverify':
/root/fwtk/fwtk/auth/pass.c:41 undefined reference to 'crypt'
pass.o:In function 'passset':
/root/fwtk/fwtk/auth/pass.c:72:undefined reference to 'crypt'
collect2:Id returned 1 exit status
make[1]: *** [authsrv] Error 1
....
make[1]:Entering directory '/root/fwtk/fwtk/http-gw'
cc -I .. -g -DLINUX -c -o error.o error.c
error.c:175: parse error before '__builtin_va_alist'
error.c:In function 'go_error':
error.c:179:declaration for parameter '__builtin_va_alist' but no such parameter
error.c:178:declaration for parameter 'msg' but no such parameter
error.c:177:declaration for parameter '__errno_location' but no such parameter
error.c:176:declaration for parameter 'sockfd' but no such parameter
error.c:189:declaration for parameter 'gostarterror' but no such parameter
make[1]: *** [error.o] Error 1
                             thanks a lot

_____________________________________________
��"��"�߱�����            http://ad2.263.net/cgi-bin/advert/push/redirect.cgi?aid=2452

---

From: Berend De Schouwer <[email-masked]>
Date: Fri, 16 Feb 2001 12:38:14 +0200

On Fri, 16 Feb 2001 12:18:29 [email-masked] wrote:
| [To be removed from this list send the message "unsubscribe fwtk-users"
| in the
| BODY of a mail message to [email-masked].]
| 
| dear all:
|    I'm a new to fwtk and linux,when I build fwtk under Redhat,
| so many errors come to me and i don't know how to do with it,
| the error are listed below:
| 
| make[1]:Entering directory '/root/fwtk/fwtk/auth'
| cc -g -static -o authsrv authsrv.o proto.o db.o pass.o sevio.o  
| ..libauth.a
| pass.o:In function 'passverify':
| /root/fwtk/fwtk/auth/pass.c:41 undefined reference to 'crypt'
| pass.o:In function 'passset':
| /root/fwtk/fwtk/auth/pass.c:72:undefined reference to 'crypt'
| collect2:Id returned 1 exit status
| make[1]: *** [authsrv] Error 1
| ....

Read the Makefile.  There are comments about what to do to
make crypt work.

| make[1]:Entering directory '/root/fwtk/fwtk/http-gw'
| cc -I .. -g -DLINUX -c -o error.o error.c
| error.c:175: parse error before '__builtin_va_alist'
| error.c:In function 'go_error':
| error.c:179:declaration for parameter '__builtin_va_alist' but no such
| parameter
| error.c:178:declaration for parameter 'msg' but no such parameter
| error.c:177:declaration for parameter '__errno_location' but no such
| parameter
| error.c:176:declaration for parameter 'sockfd' but no such parameter
| error.c:189:declaration for parameter 'gostarterror' but no such
| parameter
| make[1]: *** [error.o] Error 1

Redhat 7.0?  With the broken C compiler? :)

|                              thanks a lot
| 
|            
| 
| _____________________________________________
| ÓÐ"Àñ"×ß±éÌìÏÂ            http://ad2.263.net/cgi-bin/advert/push/redirect.cgi?aid=2452
| 
Kind regards,				  
Berend                                  

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Berend De Schouwer, +27-11-712-1435, UCS