Subject: Configuring socks-gw

From: "Larry Jackson" <[email-masked]>
Date: Sun, 15 Apr 2001 18:56:34 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

I just downloaded socks-gw from the FWTK Patches section.
I compiled and installed it OK, but there are no docs.

How do I configure the socks-gw proxy
( netperm-table and inetd.conf entries please) ?

I'm trying to use socks-gw to run gnutella through my personal firewall.

P.S. Has any more work been done on this proxy?

Thanks,
[email-masked]

On  2000-01-04 "Yakov Kravets" <[email-masked]> said:
>
> I have put together a socks-gw proxy. 
> From the name you can tell that it implements SOCKS protocol. 
> The goal for this project was to integrate SOCKS proxy into FWTK.
> At this time it only implements CONNECT request and 
> I'm working on getting BIND done.
>
> HNY everybody.
>
> -------------------------------------
> Yakov Kravets, CISSP, NeubergerBerman

---

From: "Larry Jackson" <[email-masked]>
Date: Sun, 15 Apr 2001 22:25:49 -0400

I don't know ANYTHING about socks-gw or the NEC socks daemon.

I'm trying to run GNUtella through my personal firewall
using the ToadNode client and I saw it supports socks.
I went to fwtk.org and found socks-gw.

What are the advantages/disadvantages between them.

P.S. I was astonished to see GNUtella sending packets out
using ports 137-139, ie Windows Networking/ NetBIOS.

Thanks,
[email-masked]

----- Original Message -----
"Ted Keller" <[email-masked]> asked:

> So why don't you just run the socks daemon?
>
> ted keller
>
>
> On Sun, 15 Apr 2001, Larry Jackson wrote:
>

---

From: Ted Keller <[email-masked]>
Date: Sun, 15 Apr 2001 22:58:21 -0400 (EDT)

Socks5 is available from www.socks.nec.com.  It is freely available for
non-commercial use.  I think you fit that bill.

Socks allows you to control who make a connection to what computers and
for which protocols.  It does include support for both udp and tcp
packets.  Now saying that, if you permit your local computer through the
socks daemon - using an unsafe protocol, socks will gladly let you do
that.  It operates more as a circuit proxy as opposed to a true
application proxy.  It's primary purpose is to grant/deny access - not
analyze protocl and ensure what you are doing is safe.

If you trust this program - give it a try.

ted keller

---

From: Ted Keller <[email-masked]>
Date: Sun, 15 Apr 2001 22:16:49 -0400 (EDT)

ted keller

---

From: [email-masked]
Date: Tue, 17 Apr 2001 14:47:52 +0400

nuqneH,

Let me guess.. Because it is too complex, its security is questionable
and it cannot be configured via netperm-table.

> > > I'm working on getting BIND done.

                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!