Subject: Re: install http-gw (Why run it as a daemon?)

From: "Larry Jackson" <[email-masked]>
Date: Wed, 28 Mar 2001 14:12:38 -0500

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

What is the advantage of runnning http-d as a daemon, compared to runnning
it via inetd?

Thanks,
[email-masked]
----- Original Message -----
From: "Rick Murphy" <[email-masked]>
To: "wei zheng" <[email-masked]>; <[email-masked]>
Sent: Tuesday, March 27, 2001 9:04 PM
Subject: Re: install http-gw

 > [To be removed from this list send the message "unsubscribe fwtk-users" in
the
 > BODY of a mail message to [email-masked].]
 >
 > At 11:38 PM 3/26/01 -0600, wei zheng wrote:
 > >My questions are:
 > >
 > >What port should http-gw use? If it uses port 80, what port should httpd
 > >use on the same machine? How to specify them? In which files?
 >
 > The http-gw can use any port you like, but it is typically configured to
 > use port 80. It is highly inadvisable to use a http daemon (httpd) on your
 > firewall.
 >
 > >What should the entries look like in inetd.conf and netperm-table?
 >
 > Don't put anything for http in the inetd.conf, a line like
 > /usr/local/bin/http-gw -daemon 80
 > in your rc.local, rc.inetd, or some other startup file.
 > in your netperm-table, something like:
 >
 > http-gw: userid uucp
 > http-gw: permit-hosts 1.2.3.4
 > http-gw: deny-hosts *
 > http-gw: permit-destination *
 >
 > is enough to get it working. (1.2.3.4 in the "permit-hosts" line above is
 > your internal network.)
 >
 > >How could I tell the browser the existence of http-gw?
 >
 > Configure the web proxy on your browser to use the firewall port 80 (or
 > whatever port http-gw uses.)
 >
 > >And after the inetd is reloaded, when the client on an inside machine
 > >wants to connect to an outside http server, what URL should I enter in
 > >the client brower's URL bar?
 >
 > If you set the proxy in the browser, the user simply enters the URL. If
you
 > don't use a proxy, you must use the
 > "http://firewall/http://external-host/directory" form.
 >          -Rick
 >
 >

---

From: Rick Murphy <[email-masked]>
Date: Tue, 27 Mar 2001 21:04:35 -0500

http-gw: userid uucp

 >the client brower's URL bar?

If you set the proxy in the browser, the user simply enters the URL. If you 
don't use a proxy, you must use the 
"http://firewall/http://external-host/directory" form.
          -Rick

---

From: David Lang <[email-masked]>
Date: Wed, 28 Mar 2001 12:16:22 -0800 (PST)

you avoid the HUGE overhead that you get from inetd as well as the large
startup overhead for each connection.

David Lang

On Wed, 28 Mar 2001, Larry Jackson wrote:

 > Date: Wed, 28 Mar 2001 14:12:38 -0500
 > From: Larry Jackson <[email-masked]>
 > To: FWTK List Server <[email-masked]>
 > Cc: Rick Murphy <[email-masked]>
 > Subject: Re: install http-gw (Why run it as a daemon?)
 >