Subject: RE: New version, when ?

From: Antuan Avdioukhine <[email-masked]>
Date: Thu, 19 Apr 2001 10:37:15 +0400 (MSD)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

On Wed, 18 Apr 2001, Tony Gale wrote:

> The trouble is the model is simply wrong for anything approaching high
> request rates.
	Tony, what is -- high request rate? And why firewall have to be an
perfomance giant? 

> I should, at this point, declare that I have been developing a replacement
> for the http-gw for a while. It's not feature complete yet, and a couple of
> areas need work, but it's getting there.
	Have you tried squid-gw by Mattes (em-gw tools)? It seems to be
smart enough and introduces good perfomance.

> The FWTK design uses a fork()-per-request model, which has the advantage of
> simplicity and being very forgiving of coding errors, but suffers some
> serious performance issues.
	Simplicity is the only requirement for programming of security
tools. Trying to build smart monster with fantastical perfomance you may
produce something like M$ ISA. Is it good idea?

--
Antuan Avdioukhine (DEKA-RIPN)
InternetMedia Holding Ltd.
St.Petersburg, Russia. +7 (812) 320 8585

---

From: Antuan Avdioukhine <[email-masked]>
Date: Thu, 19 Apr 2001 10:37:15 +0400 (MSD)