Subject: Strange problems - maybe caused by squid-gw?

From: Gerd Schering <[email-masked]>
Date: Mon, 23 Apr 2001 11:12:09 +0200

Hi all,

we use the FWTK-2.1 on a redhat 6.2 box. We use squid-gw
on the firewall to forward the http requests to our proxy.
We experience the folloing strange problem:

If squid-gw cannot retrieve the page from the proxy, no login
is possible on the firewall until the request is satisfied
or timed out.
It seems, that only the login process is blocked, because 
everything else seems to work fine.

We are not definitely shure that this problem is due to squid-gw
or maybe caused by something else.
We upgraded already the kernel from 2.2-17 to 2.2-19, but
it did not help.
Did anyone experience similar problems?
Any help would be welcome!

Gerd
------------------------------------------------------
-- Gerd Schering
-- Email: [email-masked]
-- TU Berlin, Zentraleinrichtung Rechenzentrum
-- Sekr. E-N 50, Einsteinufer 17, 10587 Berlin

------------------------------------------------------

---

From: Ted Keller <[email-masked]>
Date: Mon, 23 Apr 2001 08:43:31 -0400 (EDT)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Gerd,

I don't use squid-gw, but I have seen instances when using other proxies
of some remote machines not consistently terminating a transactions with
the traing <fin> (EOF) character.  The becomes especailly troubles on some
http 1.1 type servers - where content length is apparently sufficient via
rfc to tell the remote host the transmission is complete.

You may want to "snoop" your comminications line and see if all tcp
sessions are terminated with the trailing <fin>.

tek