Subject: SSH to the Internet

From: Markus Schreier <[email-masked]>
Date: Fri, 15 Jun 2001 23:32:36 +0200

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Hello all,
i've found a simmilar thread in the Archives. But there didn't seem to
be an answer. 
Perhaps someone can help.

I need my users tu connect to a couple (one up to five) of Servers
outside our Firewall. I would like to set up some ssh-Solution. At least
the Communication between FW and Server should be encrypted.

    internal net          :     external Net 
 encryption nice to have  :   encryption essential
                          :
                                   Server X   Server Y                  
client A--+          +------+         |         |
          +----------+ FWTK +---------+---------+
          |          +------+  
client B--+                
          |
          |
client C--+

I'm wondering if i could use plug-gw. To Tunnel ssh from Inside to
Outside
* Pros: both sides are encrypted
* Cons:
   a) I would need diffrent plug-gw on diffrent ports for every Server
to reach.
   b) The server would see One Client (the FWTK-Box) but it would always
get      diffrent Host-Authentications from the diffrent Clients (A B
and C)

Is anyone out there, who has a better solution than Plug-gw?

a) Is there a possibility to get diffrent plug-gw on the same port on
one Server (for instance with ip-aliassing). It would be more convinient
for the users...

b) Is there a possibility to let the server accept all thre
client-authentications, even though they al seem to come from one
IP-Source?

Thanks for any suggestions, hints and tips

Markus Schreier

Systeme & Netze
ORDIX AG

---

From: Markus Schreier <[email-masked]>
Date: Tue, 19 Jun 2001 21:12:29 +0200

Hello,
Thanks for your (and other) ideas.
How dos this work, if i have mor than one client which needs to connect
throughthe plug-gw to a server?

Does anyone have experiance with this?

Markus Schreier

"Michael St. Laurent" schrieb:
> 
> I've used plug-gw to solve this problem at one of my clients.  Just have
> plug-gw listen to a different port number for each target ssh server and
> then plug through to the ssh port.
> 
> --------------------
> Michael St. Laurent
> Hartwell Corporation
> 
> > -----Original Message-----
> > From: Markus Schreier [mailto:[email-masked]]
> > Sent: Friday, June 15, 2001 2:33 PM
> > To: [email-masked]
> > Subject: SSH to the Internet
> >
> >
> Come and meet Hartwell and HASCO at the 2001 Paris Airshow
> June 17-24, 2001
> Hall: 3 Stand: E-2