Subject: Secure Shell

From: "Don" <[email-masked]>
Date: Fri, 13 Jul 2001 16:20:57 -0400

Hi,

I've set up a SSH server on my RedHat Linux 6.2 server.  I also have the Internet firewall toolkit 2.1 with all available patches installed.  Using any Secure Shell client software, I am able to log on to my server through the internet from any external internet connection.

My question is as such: Is there a facility within the FWTK that will restrict SSH logins from specific I.P's that I specify, possibly within the netperm-table file??

Thanks,
Don

---

From: Ted Keller <[email-masked]>
Date: Fri, 13 Jul 2001 20:43:52 -0400 (EDT)

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

Don,

SSH supports the concept of AllowHosts that are permitted to connect to
the machind.  The allowable hosts are listed by IP numbers separated by
spaces if I remember coorectly.

ted keller

---

From: [email-masked]
Date: Mon, 16 Jul 2001 14:24:48 +0400

-----BEGIN PGP SIGNED MESSAGE-----

There is a problem with it: original ssh does not provide ip to authsrv when
doing authentication. The patch is simple, though.

OpenSSH does not have authsrv support at all, though you can import it easy.

And - you need "permit-authentication" patch for authsrv to do it. The one i
posted an year ago or so is broken (typo in it). No one did complain so i think
no one uses it.

You can enforce the restriction via sshd configuration itself, though.
Does not look so pretty as netperm-table but still works.

P.S. please don't use html in your mail.

"Don" <[email-masked]> said :

> This is a multi-part message in MIME format.
> 
> ------=_NextPart_000_0156_01C10BB7.CC5619C0
> Content-Type: text/plain;
> 	charset="Windows-1252"
> Content-Transfer-Encoding: quoted-printable
> 
> Hi,
> 
> I've set up a SSH server on my RedHat Linux 6.2 server.  I also have the =
> Internet firewall toolkit 2.1 with all available patches installed.  =
> Using any Secure Shell client software, I am able to log on to my server =
> through the internet from any external internet connection.
> 
> My question is as such: Is there a facility within the FWTK that will =
> restrict SSH logins from specific I.P's that I specify, possibly within =
> the netperm-table file??
> 
> Thanks,
> Don

                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!