Subject: Re: smap spam patch problems

From: Rick Murphy <[email-masked]>
Date: Fri, 17 Aug 2001 13:02:24 -0400

[To be removed from this list send the message "unsubscribe fwtk-users" in the
BODY of a mail message to [email-masked].]

At 04:55 PM 8/17/01 +0200, [email-masked] wrote:
>[To be removed from this list send the message "unsubscribe fwtk-users" in the
>BODY of a mail message to [email-masked].]
>
>Hello everybody,
>
>I tend to have a problem with Joe Yao's smap patch. While the
>general relaying-protection works nicely, I can't get any of the
>other anti-spam functions to work.
>
>Here's an excerpt from netperm-table:
>
>#smap:          spam-block deny moutvdom00.kundenserver.de
>smap:           spam-block deny [email-masked] *
>smap:           spam-block deny [email-masked] [email-masked]

I have "smap:   spam bad.domain" for my block entries.
However, you've got it right below:

>smap:           scrub-spam 1
>smap:           spam moutvdom00.kundenserver.de herbst-sendler.de 
>server.herbst-
>sendler.de
>#smap:          deny spam fw08.t-online.net
>#smap:          check-from-address 1
>
>So, what I desperately tried to achieve was blocking all mails
>from herbst-sendler.de and server.herbst-sendler.de . The
>sending MX itself had its IP resolving to
>moutvdom00.kundenserver.de, so I tried that as well. To no
>avail, mail is still accepted. Can anyone give me a hint as to
>what I've done wrong???

Does the host that's sending the mail have a valid reverse DNS? If not, 
you'll have to use IP addresses rather than hostnames - smap takes the 
address of the connecting host and uses a reverse DNS lookup to find the 
hostname.
         -Rick

---

From: [email-masked]
Date: Fri, 17 Aug 2001 19:18:34 +0200 (CEST)

Hi,

> address of the connecting host and uses a reverse DNS lookup

Well, it reverse resolved to the kundenserver.de hostname, so it
should have blocked at least that. I hadn't tried an IP adress
though. 

Cheers and thanks, 
jan
-- 
Radio HUNDERT,6 Medien GmbH Berlin
- EDV -
[email-masked]

---

From: [email-masked]
Date: Fri, 17 Aug 2001 16:55:09 +0200 (CEST)

Hello everybody,

smap, smapd:    userid daemon
smap, smapd:    directory /var/spool/smap
smap:           domains *.hundert6.de hundert6.de hundert6.com
*.hundert6.com *.
hundertsechs.de hundertsechs.de radio.hundert6.de
*.hundertsechs.com hundertsech
s.com
smap:           hosts mail.inhundert6.de
smapd:          executable /usr/local/etc/smapd
smapd:          sendmail /usr/sbin/sendmail
smap:           timeout 7200
#smap:          spam-block deny moutvdom00.kundenserver.de
smap:           spam-block deny [email-masked] *
smap:           spam-block deny [email-masked] [email-masked]
smap:           scrub-spam 1
smap:           spam moutvdom00.kundenserver.de
herbst-sendler.de server.herbst-
sendler.de
#smap:          deny spam fw08.t-online.net
#smap:          check-from-address 1

Cheers,

Jan