Subject: [fwtk-users] x-gw seg fault !!

From: "Alexandre Ghisoli" <[email-masked]>
Date: Tue, 30 Oct 2001 19:38:07 +0100

Hi there,

I've problems with x-gw.
It's seg. fault !!

After some gdb and mailarchives/doc red, it seems that it is in sws.c the
problem, when freesws is called.
But when I destroy the memory management, main() crashes also :-(

Could you help me ?
It's a urgent problem to solve.

Best regards.

	--Alexandre

Config :
Slackware 8
gcc (tryed on different version - 2.96 - 3)

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Tony Gale <[email-masked]>
Date: 31 Oct 2001 09:47:43 +0000

Have you applied the jumbo patch from www.fwtk.org? It contains a memory
usage bugfix for x-gw (and a security fix).

-tony

On Tue, 2001-10-30 at 18:38, Alexandre Ghisoli wrote:
> You are currently subscribed to fwtk-users as: [email-masked]

---

---

From: Tony Gale <[email-masked]>
Date: 31 Oct 2001 16:07:36 +0000

But... the fact that it is calling freesws at all indicates a problem,
as that is an error condition in the parsing of the command line
arguments that have been passwd to x-gw. So, how have you configured
x-gw exactly, and what do you do to trigger this error?

-tony

---