Subject: [fwtk-users] http-gw thru a squid proxy ??

From: "MARCON Michel, CETU/SG/Informatique" <[email-masked]>
Date: Fri, 19 Oct 2001 08:39:43 +0200

Hello.

I want to use http-gw but to redirect its requests to a squid proxy. I
fumbled everywhere, but haven't found any command line option to dothat.

 client-Iexplore-->http-gw-->SuidProxy-->Internet

Any Hint ??

TYA

--------------------------
Michel Marcon
SysAdmin Unix & Windows NT
Ministere Equipement, CETU
Tel (33) 04 7214-3408

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Fri, 19 Oct 2001 08:56:42 +0200

Hi,

perhaps you should look at the following link:
http://www.squid-cache.org/Doc/FAQ/FAQ-4.html#ss4.16

Regards, Juergen

Juergen Streck
PRUEFTECHNIK AG
Oskar-Messter-Straße 19-21
85737 Ismaning
www.pruftechnik.com

---

---

From: "MARCON Michel, CETU/SG/Informatique" <[email-masked]>
Date: Fri, 19 Oct 2001 10:10:56 +0200

Hello.
Fine answer, but....

> -----Message d'origine-----
> De : [email-masked]
> [mailto:[email-masked]]
> Envoyé : vendredi 19 octobre 2001 08:57
 
> http://www.squid-cache.org/Doc/FAQ/FAQ-4.html#ss4.16
In this exemple http-gw is the front-end and squid passes it requests to it.
What I want to is the reverse. And I cannot make any change on the Squid
wich is out of reach (I'm not the sysadmin of it).

Thanks for the tip, however.
> You are currently subscribed to fwtk-users as: 
> [email-masked]

---

---

From: Rick Murphy <[email-masked]>
Date: Fri, 19 Oct 2001 06:07:48 -0400

>wich is out of reach (I'm not the sysadmin of it).

I don't think there's anything you can do to make this work.
It's exactly the same situation as installing the firewall toolkit and 
http-gw to protect a network; when you do that, you must tell the users to 
configure their web browsers to use the firewall as their proxy. When you 
do that, the browser sends the full URL to the firewall, including the 
hostname. In your case, you've got to reconfigure the squid system to use 
the proxy as well.
A transparent http proxy (like those in commercial firewalls) wouldn't have 
this problem.
         -Rick

---

---

From: Gerd Schering <[email-masked]>
Date: Mon, 22 Oct 2001 08:51:26 +0200

Have a look at squid-gw.
I think you'll find in the patches section of fwtk.org under
-> Other addons 
-> Proxies for NNTP, POP3, Squid, and other services such as traceroute
(em-gw)

Gerd

"MARCON Michel, CETU/SG/Informatique" wrote:
> You are currently subscribed to fwtk-users as: [email-masked]

-- 
------------------------------------------------------
-- Gerd Schering
------------------------------------------------------

---

---

From: Ian Mortimer <[email-masked]>
Date: Tue, 23 Oct 2001 11:38:23 +1000

> wich is out of reach (I'm not the sysadmin of it).

This works here (but will depend on how your squid proxy is configured):

http-gw:        default-http    http-proxy.our.net
http-gw:        default-gopher  gopher-proxy.our.net
http-gw:        ftp-proxy       ftp-proxy.our.net

-- 
Ian
     [email-masked]    Ian Mortimer
     Tel: +61 7 3365 3436     Department of Physics
     Fax: +61 7 3365 1242     University of Queensland

-- 
Ian
     [email-masked]    Ian Mortimer
     Tel: +61 7 3365 3436     Department of Physics
     Fax: +61 7 3365 1242     University of Queensland

---