Subject: [fwtk-users] ICQ With FWTK

From: Fritsch Jonathan D CONT PSNS <[email-masked]>
Date: Thu, 18 Oct 2001 07:12:52 -0700

> How is this done?
> What is Configuration to allow ICQ?
> Use udprelay on port 4000. Relay to icq.mirabilis.com then point your
> clients to the firewall. 
> Disadvantage: file transfers don't work - udprelay only works for ICQ
> chat. 
> 
> Thank You For any help you may provide.
>   Jonathan Fritsch
> 

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Thu, 18 Oct 2001 18:34:56 +0400 (MSD)

nuqneH,

Moving to icq2000 and dropping the old udp protocol completely may be a better
option.

-- 
                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!

---

---

From: Fritsch Jonathan D CONT PSNS <[email-masked]>
Date: Thu, 18 Oct 2001 07:49:08 -0700

And in lame name terms that means what?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 18, 2001 7:35 AM
To: fwtk-users
Subject: [fwtk-users] Re: ICQ With FWTK

nuqneH,

Moving to icq2000 and dropping the old udp protocol completely may be a
better
option.

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: [email-masked]
Date: Thu, 18 Oct 2001 18:47:57 +0400

-----BEGIN PGP SIGNED MESSAGE-----

That means icq2000b and later does support CONNECT-style proxy, so you
can pass it through firewall using your favorite one (plug-gw in ssl mode,
squid-gw or ssl-gw)

                                     _     _  _  _  _      _  _

---

---

From: "Don" <[email-masked]>
Date: Thu, 18 Oct 2001 11:36:14 -0400

Does this mean that we have to configure ICQ client to use HTTPS proxy?

----- Original Message ----- 
From: <[email-masked]>
To: "fwtk-users" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, October 18, 2001 10:47 AM
Subject: [fwtk-users] Re: ICQ With FWTK

> -----BEGIN PGP SIGNATURE-----
> Version: PGP 6.5.1i
> 
> iQCVAwUBO87rmaH/mIJW9LeBAQHblwP9Fj/X+NDPuPX6c1T4JWptu6MkixLoXbrI
> 231AJ8trT5FXXNIQ2MtxbkDwH/JuNqH9OxFnK6Y8IdDF48xHnBlVzk7LWm9cpJdG
> Ml3ir7I2Y2ZFFunTJpPvxPZsGldQnNVtFQen+/IZyElk7bK2x0R5SQsD6CAg8068
> gl96POlQUEM=
> =D9gP
> -----END PGP SIGNATURE-----
> 
> ---
> You are currently subscribed to fwtk-users as: [email-masked]

---

---

From: [email-masked]
Date: Thu, 18 Oct 2001 19:36:37 +0400 (MSD)

nuqneH,

Yes. That provides you a nice side effect: you get rid of banners
authomagically - icq2000 tries to obtain banners by applying GET method to
HTTPS proxy (which is not expected to handle it ;)

---

---

From: "Don" <[email-masked]>
Date: Thu, 18 Oct 2001 12:40:17 -0400

And my understanding is (please correct me if I am wrong), if I have not purchased and installed a certificate, I cannot use SSL and
therefore, cannot use ICQ through FWTK 2.1?

----- Original Message -----
From: <[email-masked]>
To: "fwtk-users" <[email-masked]>
Sent: Thursday, October 18, 2001 11:36 AM
Subject: [fwtk-users] Re: ICQ With FWTK

---

---

From: Antuan Avdioukhine <[email-masked]>
Date: Thu, 18 Oct 2001 20:46:31 +0400 (MSD)

On Thu, 18 Oct 2001, Don wrote:

> And my understanding is (please correct me if I am wrong), if I have
> not purchased and installed a certificate, I cannot use SSL and
You are wrong. SSL and SSL proxy are different things. ICQ2000b+ uses
"CONNECT-style" proxy, ssl-gw _is_ such one. "CONNECT-style" proxy just
receives "CONNECT <host:port> .." string then acts like plug-gw.

-- 
Antuan Avdioukhine (DEKA-RIPN)
InternetMedia Holding Ltd.
St.Petersburg, Russia. +7 (812) 320 8585

---

---

From: "Don" <[email-masked]>
Date: Thu, 18 Oct 2001 13:03:20 -0400

> receives "CONNECT <host:port> .." string then acts like plug-gw.

Thanks for your reply.  I would like to know if I have everything set properly.  Using RedHat Linux 6.2

1) In /usr/local/etc/netperm-table file, I have the following:

   # outbound ssl
   netacl-ssl: permit-hosts * -exec /usr/local/etc/ssl-gw

# secure http
ssl-gw:         denial-msg /usr/local/etc/http-deny.html
ssl-gw:         timeout 36000
ssl-gw:         permit-hosts 205.205.137.*
ssl-gw:         deny-hosts *

2) In /etc/inetd.conf, I have the following:

ssl             stream  tcp     nowait  root    /usr/local/etc/netacl ssl

3) in /etc/services, I have the following:

ssl             444/tcp

4) How do I configure my ICQ 2000b to use the proxy? In my connection settings,
  a) I have checked "Using Firewall"
  b) I have checked "Connect using proxy"
  c) I have entered my proxy Host name
  d) I have enters Port: 444 (is thsi correct)?
  e) I have checked HTTPS
  f) I enter my Username/Password (any real user will do I assume?)

Unfortunately, ICQ is still unable ro register so there must be a miscong. somewhere

---

---

From: Antuan Avdioukhine <[email-masked]>
Date: Thu, 18 Oct 2001 21:16:44 +0400 (MSD)

>    netacl-ssl: permit-hosts * -exec /usr/local/etc/ssl-gw
hmm...
> ssl-gw:         permit-hosts 205.205.137.*
looks good

> ssl             stream  tcp     nowait  root    /usr/local/etc/netacl ssl
maybe use
ssl          stream  tcp     nowait  root    /usr/local/etc/ssl-gw ssl-gw
?

> 3) in /etc/services, I have the following:
ok

>   f) I enter my Username/Password (any real user will do I assume?)
nope. ssl-gw does not support Proxy-authenticate method. use blank fields

---