Subject: [fwtk-users] Question about plug-gw

From: [email-masked]
Date: Fri, 30 Nov 2001 09:28:27 +0100

Hello,

we are desperately trying to get Sourcegears Source Offsite running with
plug-gw. Source Offsite uses normally port 8888, so it should be no problem
to plug that port through the firewall. But whenever I connect to the
Offsite server, the server immediately closes the connection. There´s a
statement in the help of Source Offsite that "it will only work with
proxies that enables CONNECTS". I contacted support of Sourcegear to ask
them what they mean and here is the answer from them:
> Basically, what we mean by CONNECTS is that the proxy must be configured
to
> allow completely stateless transactions to pass.  Most proxies are
> initially configured to only allow one message at a time to pass.
However,
> SourceOffSite requires an open connection.  This is analogous to SSL
> tunneling.  In fact, the proxy may even offer that as a checkable option.

Can you tell me if that is somehow possible with plug-gw, or is there an
add-on which will enable this kind of connection ?
Thanks in advance for your help.
Regards, Juergen

Juergen Streck
PRÜEFTECHNIK AG
Oskar-Messter-Straße 19-21
85737 Ismaning
www.pruftechnik.com
Tel: +49 (0)89 99616-206
Fax: +49 (0)89 99616-200

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Michel Bardiaux <[email-masked]>
Date: Fri, 30 Nov 2001 10:11:56 +0100

> Thanks in advance for your help.

plug-gw must be started with the "-ssl" option.

Are you able to access secured web pages (i.e. URLs beginning with
https://) from your browser? If so, then you could point "Source
Offsite" to the same port on the firewall that the browser uses as
"secure proxy", usually 443. Or, configure plug-gw on port 8888 the same
way as the one on port 443.

Could you post your related inetd.conf (or init.d scripts) and
netperm-table entries?

> You are currently subscribed to fwtk-users as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Michel Bardiaux
Peaktime Belgium S.A.  Rue Margot, 37  B-1457 Nil St Vincent
Tel : +32 10 65.44.15  Fax : +32 10 65.44.10

---

---

From: [email-masked]
Date: Fri, 30 Nov 2001 10:58:16 +0100

I just added "-ssl" to my plug-gw line in netperm.table AND IT WORKS !
Stupid me ;-) Never thought it could have been so simple. Thanks for the
hint.

Regards, Juergen

Juergen Streck
PRUEFTECHNIK AG

                    Michel                                                                                    
                    Bardiaux             To:     "fwtk-users" <[email-masked]>                   
                    <mbardiaux@pea       cc:                                                                  
                    ktime.be>            Subject:     [fwtk-users] Re: Question about plug-gw                 
                                                                                                              
                    30.11.2001                                                                                
                    10:11                                                                                     
                    Please respond                                                                            
                    to                                                                                        
                    "fwtk-users"                                                                              

---
You are currently subscribed to fwtk-users as:
[email-masked]
To unsubscribe send a blank email to [email-masked]

---