Subject: [fwtk-users] Usage of authsrv and time

From: [email-masked]
Date: Wed, 30 Jan 2002 14:22:27 +0100

Hello.

I want to start and stop ftp-gw service (I use ftp-gw thru authsrv) only on
certain hours of the day.
I noticed the "time" option of authsrv for that pupose; it mut be used with
the -extnd option of ftp-gw. But I am unable to make it work.
Anyone has a solution for this kind of problem ??

TYA

--------------------------
Michel Marcon
SysAdmin Unix & Windows NT
Ministere Equipement, CETU
Tel (33) 04 7214-3408

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Rick Murphy <[email-masked]>
Date: Wed, 30 Jan 2002 18:32:32 -0500

>Anyone has a solution for this kind of problem ??

I've never tried to make this work, but here's how it's supposed to work.

You must run ftp-gw with the -extnd option.

You have authsrv lines in the netperm-table like:

authsrv:        permit-unknown unauth
authsrv:        permit-operation ftp-gw user <user> <command> <dest> <tokens>
authsrv:        permit-operation ftp-gw group <group> <command> <dest> <tokens>

The first line is required if you don't enable authentication. In that 
case, the only form of the "operation" line that works is the "user unauth" 
type.

For ftp-gw, "<command>" can be RETR, STOR, etc.
The "<tokens>" field should be something like
         time 17:00 23:59
to allow time between 17:00 and 23:59

If you'll post the way you're trying to configure it - and what errors 
you're seeing - I can make better suggestions.
         -Rick

---