Subject: [fwtk-users] smap compilation error afther applying yao patch

From: Per Gustav Ousdal <[email-masked]>
Date: Fri, 8 Feb 2002 02:51:05 +0100

Hi

I get the following error when building:

smap.c:2570 macro `strpbrk` used without args
make[1]: *** [smap.o] Error 1

System info:
Linux 2.4.10 (SuSE Linux 7.3)
gcc ver. 2.95.3
libc-2.2.4

Any ideas?

Regards,

Per

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Per Gustav Ousdal <[email-masked]>
Date: Fri, 8 Feb 2002 03:03:39 +0100

> Linux 2.4.10 (SuSE Linux 7.3)

Sorry but I forgot to mention that we are talking about fwtk 2.1 with the 
"jumbo" patch applied, but the smap.c should be "clean"

Per

---

---

From: Rick Murphy <[email-masked]>
Date: Thu, 07 Feb 2002 20:01:26 -0500

>make[1]: *** [smap.o] Error 1

Your system defines strpbrk as a macro; line 2570 probably reads
extern char *strpbrk();

Comment out that line and it'll probably build OK.
         -Rick

---

---

From: Per Gustav Ousdal <[email-masked]>
Date: Fri, 8 Feb 2002 03:35:54 +0100

> Your system defines strpbrk as a macro; line 2570 probably reads

Guess what? It DOES ;)

> Comment out that line and it'll probably build OK.

Right again. Thanks a lot!

Any comments on what patches are worthwhile? Or rather, should be considered 
"musts"?

Another minor problem: I also apllied the ipbind patch. And I get this error:

rlogin-gw.c: In function 'main':
rlogin-gw.c:164: warning: assignment makes pointer from integer without cast

The rlogin-gw builds, and I don't think I'll ever use it. However I am a fan 
of nice clean compiles, and it seems like a really minor problem: Any ideas 
on that?

>From what I can understand the error is that a variable is "converted" in the 
wrong mannor, however I don't know c syntax :(

Per 

---

---

From: Rick Murphy <[email-masked]>
Date: Fri, 08 Feb 2002 17:39:28 -0500

>Any comments on what patches are worthwhile? Or rather, should be considered

I'll leave that to the people running in 'production' environments..

>rlogin-gw.c:164: warning: assignment makes pointer from integer without cast

What does this line read in your version of the (patched) source?
         -Rick

---

---

From: "Michael St. Laurent" <[email-masked]>
Date: Fri, 8 Feb 2002 14:52:13 -0800

Well we use your version of the anti-spam patches Rick and I'm definitely in
a "production" environment.  They're very stable.

--------------------
Michael St. Laurent
Hartwell Corporation

> -----Original Message-----
> From: Rick Murphy [mailto:[email-masked]] 
> Sent: Friday, February 08, 2002 2:39 PM
> To: fwtk-users
> Subject: [fwtk-users] Re: smap compilation error afther 
> applying yao patch
> 
> 
> You are currently subscribed to fwtk-users as: [email-masked]

---

---

From: Per Gustav Ousdal <[email-masked]>
Date: Mon, 11 Feb 2002 21:41:21 +0100

On Friday 08 February 2002 23:39, you wrote:
> >Any comments on what patches are worthwhile? Or rather, should be
> > considered "musts"?
>

Oh, oh :) 

In general I find it a hassle to apply more than one patch to any given file 
:) Does anyone have any tips on that?

BTW: I did find this link helpful on patches:
http://www.math.washington.edu/~chappa/pine/faq/

It's actually for pine, but has a lot of good general info too.

> What does this line read in your version of the (patched) source?

It reads: 
colon = strchr(ip,':');

Per

---