Subject: [fwtk-users] plug-gw as a ssh proxy.

From: Ian Mortimer <[email-masked]>
Date: Tue, 26 Mar 2002 13:41:40 +1000

I'm trying to use plug-gw as a one to one ssh proxy.

The setup is:

/etc/services:

   sshgw           2022/tcp    #Secure Shell Login gateway

/etc/inetd.conf:

   sshgw   stream  tcp     nowait  root    /usr/local/etc/plug-gw  plug-gw 
sshgw

/usr/local/etc/netperm-table:

   plug-gw:        timeout 900
   plug-gw:        userid  root
   plug-gw:        groupid nobody
   plug-gw:        port 2022 10.1.1.3 -plug-to 10.2.2.2 -port ssh

Doing `ssh -p 2022 fwtk-host' gets:

   ... plug-gw[3236]: deny host=.../10.1.1.3 service=sshgw

I think this should be possible even using the non-standard port 2022
for the initial connection but obviously I'm doing something wrong.
Can anyone see what's wrong with this setup?

Thanks

-- 
Ian
     [email-masked]    Ian Mortimer
     Tel: +61 7 3365 3436     Department of Physics
     Fax: +61 7 3365 1242     University of Queensland

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Larry Moore" <[email-masked]>
Date: Tue, 26 Mar 2002 12:06:51 +0800

I would suggest searching the mailliing list archives for vnc-gw.

You should find a message from me about overcoming such a problem with
vnc-gw.

Cheers,

Larry.
----- Original Message -----
From: "Ian Mortimer" <[email-masked]>
To: "fwtk-users" <[email-masked]>
Sent: Tuesday, March 26, 2002 11:41 AM
Subject: [fwtk-users] plug-gw as a ssh proxy.

> You are currently subscribed to fwtk-users as: [email-masked]

---

---

From: lebayle <[email-masked]>
Date: Tue, 26 Mar 2002 08:33:08 +0100 (MET)

Just replace the string 2022 with sshgw in netperm-table, in order to be 
consistent with inetd.conf. It should work.

Bruno LEBAYLE ([email-masked])
European Synchrotron Radiation Facility - Grenoble, FRANCE

>Date: Tue, 26 Mar 2002 13:41:40 +1000
>From: Ian Mortimer <[email-masked]>
>List-Unsubscribe: <mailto:[email-masked]>
>
>You are currently subscribed to fwtk-users as: [email-masked]

Bruno LEBAYLE.
_____________________________________________________________________
        o          
     o  o  o       Bruno LEBAYLE - Network group
  o   o o o   o    E.S.R.F (European Synchrotron Radiation Facility)
    o  ooo  o      BP220, 38043 GRENOBLE CEDEX 9
o o o ooooo o o o  phone (33)4-7688-2258              
    o  ooo  o      fax   (33)4-7688-2020
  o   o o o   o    email [email-masked]
     o  o  o                        
        o  http://www.esrf.fr/computing/cs/sysadmin/network/home.html
_____________________________________________________________________

---

---

From: [email-masked]
Date: Tue, 26 Mar 2002 13:42:50 +0100

Hi. (interested by both ssh anc vnc)
It would be nice if you give us a link to this [for me] mysterious vnc-gw
mail list...
TYA !!!

> -----Message d'origine-----
> De : Larry Moore [mailto:[email-masked]]
> Envoyé : mardi 26 mars 2002 05:07
> À : fwtk-users
> Objet : [fwtk-users] Re: plug-gw as a ssh proxy.
> 
> 
> You are currently subscribed to fwtk-users as: 
> [email-masked]

---

---

From: "Larry Moore" <[email-masked]>
Date: Wed, 27 Mar 2002 00:00:14 +0800

Try this link;

http://marc.theaimsgroup.com/?l=fwtk-users&m=96769978907937&w=2

Cheers,

Larry.

----- Original Message -----
From: <[email-masked]>
To: "fwtk-users" <[email-masked]>
Sent: Tuesday, March 26, 2002 8:42 PM
Subject: [fwtk-users] Re: plug-gw as a ssh proxy.

---

---

From: Ian Mortimer <[email-masked]>
Date: Wed, 27 Mar 2002 09:11:11 +1000

> http://marc.theaimsgroup.com/?l=fwtk-users&m=96769978907937&w=2

Thanks Larry.

This configuration works:

/etc/services:

/etc/inetd.conf:
   sshgw stream  tcp     nowait  root    /usr/local/etc/netacl netacl sshgw

/usr/local/etc/netperm-table:
   netacl-sshgw: permit-hosts 192.168.84.* -exec /usr/local/etc/plug-gw sshgw
   sshgw:        permit-hosts 192.168.84.*
   sshgw:        permit-service sshgw
   sshgw:        timeout 900
   sshgw:        userid  root
   sshgw:        groupid nobody
   sshgw:        port sshgw 10.1.1.3 -plug-to 10.2.2.2 -port ssh

---

---

From: Ted Keller <[email-masked]>
Date: Tue, 26 Mar 2002 22:13:13 -0500 (EST)

Change these

   plug-gw:        timeout 900
   plug-gw:        userid  root
   plug-gw:        groupid nobody

to

   sshgw:        timeout 900
   sshgw:        userid  root
   sshgw:        groupid nobody
   sshgw:        port 2022 10.1.1.3 -plug-to 10.2.2.2 -port ssh

On Tue, 26 Mar 2002, Ian Mortimer wrote:

> You are currently subscribed to fwtk-users as: [email-masked]

---