Subject: [fwtk-users] I trustingly wrote this letter...

From: "Takacs Istvan" <[email-masked]>
Date: Fri, 8 Feb 2002 07:00:47 +0100

to see it on the fwtk-users list, because this is my fourth
letter what I try to send, and never see them again...

So, first of all; Hi.

I tried to compile fwtk 2.1 on Red Hat Linux 7.2
I need just http-gw so I commented out the x-gw
options in Makefile.conf.linux then I moved this
file to Makefile.conf
When I run make, it sends an error message
which complains to ndbm.h...

cc -g -static -o authmgr authmgr.o ../libauth.a ../libfwall.a
cc -I.. -g -DLINUX   -c -o authsrv.o authsrv.c
cc -I.. -g -DLINUX   -c proto.c
cc -I.. -g -DLINUX   -c -o db.o db.c
db.c:16:25: ndbm.h: No such file or directory
make[1]: *** [db.o] Error 1
make[1]: Leaving directory `/usr/src/fwtk/auth'

[...]

and at the end the hole make process 
hangs up with x-gw error;

make[1]: Entering directory `/usr/src/fwtk/x-gw'
cc -I.. -g -DLINUX -I   -c -o child.o child.c
In file included from child.c:14:
ulib.h:26:27: X11/Intrinsic.h: No such file or directory
ulib.h:64:9: warning: extra tokens at end of #endif directive
make[1]: *** [child.o] Error 1
make[1]: Leaving directory `/usr/src/fwtk/x-gw'
make: *** [all] Error 2

What should I do to not use the X11 libs and
how can I compile the package with ndbm.h?

Thanks in advance!

Regards,

                  Istvan

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Rick Murphy <[email-masked]>
Date: Wed, 27 Mar 2002 16:43:58 -0500

>which complains to ndbm.h...

Based on my Red Hat 7.0 system, you'll need to add -I/usr/include/gdbm to 
the "CFLAGS" line in the authsrv Makefile. Change
CFLAGS= -I.. $(COPT)
to
CFLAGS= -I.. -I/usr/include/gdbm $(COPT)

At least on this system, there's a ndbm.h in that directory.
         -Rick

---