Subject: [fwtk-users] Problem with telnet proxy.

From: "Andrew Petrov" <[email-masked]>
Date: Thu, 8 Aug 2002 12:04:13 +0300

Hi managers.

I've compiled and installed FWTK 2.1 on Linux Slakware 7.0 (Intel 486)
successfully. The FWTK were configured for telnet use only.

But, I've met one strange thing.

When I try to connect to firewall from Windows workstations,
everything works fine.

But in case of trying to connect from Solaris, Cisco or BSD  I receive a message
Trying x.x.x.x
Unable to connect to remote host. Connection refused.
All stations are in the same subnet.

Here is my inetd.conf and netperm-table examples:
#
# Internet server configuration database
#
#       @(#)inetd.conf  5.4 (Berkeley) 6/30/90
#       Modified, [email-masked]
#
# modified to allow daemon mode use of proxies.
stelnet stream  tcp     nowait  root    /usr/local/etc/netacl   in.telnetd
telnet  stream  tcp     nowait   root    /usr/local/etc/tn-gw    tn-gw
authsrv stream  tcp     nowait  root    /usr/local/etc/authsrv  authsrv
auth    stream  tcp     nowait  root    /usr/local/etc/authsrv  authsrv

netperm-table.

netacl-in.telnetd: permit-hosts 127.0.0.1 -exec /usr/sbin/in.telnetd
netacl-in.telnetd: permit-hosts X.X.X.X -exec /usr/sbin/in.telnetd
netacl-in.telnetd: permit-hosts X.X.X.X -exec /usr/sbin/in.telnetd
#
# if the next line is uncommented, the telnet proxy is available
netacl-in.telnetd: permit-hosts * -exec /usr/local/etc/tn-gw

# Example telnet gateway rules:
# -----------------------------
tn-gw:          denial-msg      /usr/local/tis/tn-deny.txt
tn-gw:          welcome-msg     /usr/local/tis/tn-welcome.txt
tn-gw:          help-msg        /usr/local/tis/tn-help.txt
tn-gw:          timeout 90
# if this line is uncommented incoming traffic is permitted WITH
# authentication required
tn-gw:          permit-hosts MYNET -passok -xok
tn-gw:          permit-hosts * -auth

# Example auth server and client rules
# ------------------------------------
authsrv:        hosts 127.0.0.1
authsrv:        database /usr/local/etc/fw-authdb
authsrv:        badsleep 1200
authsrv:        nobogus true
*:              authserver 127.0.0.1 7777

Thanks for any suggestions.
Will summarize.

Andrew Petrov.
Unix SA.
Impexbank , Russia.

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Torrance, Derek" <[email-masked]>
Date: Fri, 16 Aug 2002 15:10:43 +0100

Hi Andrew,
 
Sounds like the problem may be more fundamental than a fwtk mis-configuration. Can you ping the fwtk Linux box from the Solaris/Cisco/BSD systems?
 
dt

-----Original Message-----
From: Andrew Petrov [mailto:[email-masked]]
Sent: 08 August 2002 10:04
To: fwtk-users
Subject: [fwtk-users] Problem with telnet proxy.

Hi managers.

 

netperm-table.

 

Andrew Petrov.
Unix SA.
Impexbank , Russia.
 
---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked] 

---