Subject: [fwtk-users] Is plug-gw the only option for IMAP?

From: "David L Kindred (Dave)" <[email-masked]>
Date: Mon, 19 Aug 2002 16:57:47 -0400

I have a short-term need to allow some access to an internal IMAP server
from the outside world.  A Google search seems to show that no options
exist except to either actually run an IMAP server on the outside and
copy mail to it, or to use plug-gw to pass the traffic inside.

Are there any other options?

Note: yes, I know IMAP to the outside isn't a great idea, but you have
to keep the executive staff happy.

-- 
David L. Kindred <mailto:[email-masked]>
Unix Systems & Network Administrator
Telesciences, Inc. <http://www.telesciences.com>
Support: <http://support.telesciences.com>
2000 Midlantic Drive, Suite 410, Mt. Laurel, NJ 08054
Tel: +1.856.866.1000 ext. 4184
Fax: +1.856.866.0185
Cel: +1.609.413.6205
Pgr: +1.800.689.5182
SMS: <mailto:[email-masked]>
---

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Tue, 20 Aug 2002 01:31:58 +0400 (MSD)

Selective replication to outside server is definitely better idea
than allowing imap to inside

(i am planning imap proxy somedays though)

btw for those who is interested in mail filtering we are testing
milter-enabled pop3-gw now ;-)

-- 
                                     _     _  _  _  _      _  _
 {::} {::} {::}  CU in Hell          _| o |_ | | _|| |   / _||_|   |_ |_ |_
 (##) (##) (##)        /Arkan#iD    |_  o  _||_| _||_| /   _|  | o |_||_||_|
 [||] [||] [||]            Do i believe in Bible? Hell,man,i've seen one!

---

---

From: Tony Gale <[email-masked]>
Date: 20 Aug 2002 09:19:20 +0100

> Are there any other options?

Other options:

o Run a webmail system outside that is the only box allowed to IMAP to
the internal server.

o There are some imap proxies around (google: imap proxy):  
	http://www.vergenet.net/linux/perdition/ seems to do what you want, but
I haven't even downloaded it, so use at your own risk.

o You could probably use stunnel on an external server to setup an
SSL-IMAP server to the internal mail server. Maybe.

-tony

---

---

From: Michel Bardiaux <[email-masked]>
Date: Tue, 20 Aug 2002 10:24:23 +0200

> than allowing imap to inside

Access to the internal IMAP server over ssh over plug-gw would be
somewhat more secure than plain plug-gw.

-- 
Michel Bardiaux
Peaktime Belgium S.A.  Bd. du Souverain, 191  B-1160 Bruxelles
Tel : +32 2 790.29.41

---

---

From: [email-masked]
Date: Tue, 20 Aug 2002 14:31:03 +0400

> somewhat more secure than plain plug-gw.

Somewhat. You have to keep ssh bugs in mind and windows client configuration
becomes non-trivial. And you cannot use per-ip access control on the server.

So i think replication is the only proper way.

                                     _     _  _  _  _      _  _

---

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 20 Aug 2002 12:21:04 -0600

> > >  to keep the executive staff happy.
Please don't top post it makes the thread hard to follow. Here is some 
food for thought. It has been a long time since using plug-gw but I 
see not reason why it would not work. Why not use stunnel combined with 
client based certs? You then get a number of good things IMHO:
1 - SSL/TLS to the imapd or whatever else you want..
2 - Client Cert based authentication.. (let me know how this works for you.)
    OR if you prefer simply use only the imapd server account as is..
3 - Decrypt the stream in transit so you can do traffic analysis at 
    the point of redirection in stunnel. stick in plug-gw and voila!

Hope that helps!

Best Regards,
[email-masked]

-- 
/*  Security is a work in progress - dreamwvr                 */
#                                                             
# Note: To begin Journey type man afterboot,man help,man hier[.]      
#                                                             
// "Who's Afraid of Schrodinger's Cat?" /var/(.)?mail/me \?  ;-]

---

---

From: "Michael St. Laurent" <[email-masked]>
Date: Tue, 20 Aug 2002 12:09:12 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, August 20, 2002 11:21 AM
> To: fwtk-users
> Subject: [fwtk-users] Re: Is plug-gw the only option for IMAP?

> Please don't top post it makes the thread hard to follow. 

Does anyone know how to configure Outlook to bottom post?  I can't find a
setting that will let me change this.  It always puts my signature at the
top and I have to move it to the bottom by hand.

Note:  Switching email clients is not an option here as the company mandates
use of Outlook.

-- 
Michael St. Laurent
Hartwell Corporation

---