Subject: [fwtk-users] Smap documentation

From: "Hutchison, Chris" <[email-masked]>
Date: Thu, 14 Nov 2002 13:26:30 -0500

I just upgraded to 2.1 and there are a number of new anti-spamming features
in smap.
I am a little confuse on three files and have been trying to find
documentation.
They are:

	content-file
	map-file
	spam-file
	spamlist.dat

Any help is greatly appreciated.
Chris

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Joseph S D Yao <[email-masked]>
Date: Thu, 14 Nov 2002 13:48:02 -0500

> Any help is greatly appreciated.

If you download the "Yao" compilation of patches, you will see that my
major contribution, besides a little debugging, was to comment the heck
out of the whole file.  Since that compilation, there have been other
patches; but I don't know which ones carried the comments along.

Hmmm.  I don't 'grep' any of those names in that copy, though.  If they
were in baseline 2.1, they should be in my patched version.

-- 
Joe Yao				[email-masked] - Joseph S. D. Yao
OSIS Center Systems Support					EMT-B
-----------------------------------------------------------------------
   This message is not an official statement of OSIS Center policies.

---

---

From: "Michael St. Laurent" <[email-masked]>
Date: Thu, 14 Nov 2002 12:00:25 -0800

Perhaps these are from Gauntlet?

-- 
Michael St. Laurent
Hartwell Corporation

> -----Original Message-----
> From: Joseph S D Yao [mailto:[email-masked]] 
> Sent: Thursday, November 14, 2002 10:48 AM
> To: fwtk-users
> Cc: fwtk-users
> Subject: [fwtk-users] Re: Smap documentation
> 
> 
> You are currently subscribed to fwtk-users as: [email-masked]

---

---

From: Joseph S D Yao <[email-masked]>
Date: Thu, 14 Nov 2002 17:01:43 -0500

> Perhaps these are from Gauntlet?

Certainly possible.  But then, why is he asking fwtk-users?

---

---

From: "Hutchison, Chris" <[email-masked]>
Date: Mon, 18 Nov 2002 08:08:59 -0500

Thanks for your help!

I am running fwtk 2.1 and did find the documentation for a couple of the
files.
Two of the files I am still stuck on are the map and content files.

The map file examples are as follows:

	#
	# map file....
	#
	# format - 
	# command (from/to) <from-address>   <to-address>   [max message
size]
	#
	from <[email-masked]> <[email-masked]> 0
	to <[email-masked]> <[email-masked]> 0

	from <[email-masked]> <[email-masked]> 0
	to <[email-masked]> <[email-masked]> 0

WHATS IT MAPPING??

And the content file I understand what its doing, just not how its doing it?
Whats the difference between "tag" and "string"?
What does each do?

	#
	# Note - sendmail - at times - rewrites addresses that do not
contain a domain.
	# This occurs after the spam filters have taken place.
	# The spam filters look only at the pre-rewritten address message
headdres
	# # eg. <Undisclosed Recipients> maps to
<[email-masked]>
	#
	# the smap filters must look for <Undisclosed Recipients>
	#
	# We see re-writting taking place for ....
	# addresses without domains
	# spaces in addresses (changed to .)
	#
	# This list was generated 12/16/99 16:06
	#
	tag free4all.com
	tag xxxkorea.jp
	tag udepot.com
	tag affiliatedsites.com
	string affiliatedsites.com
	tag travelpics.coms

Again any help is greatly appreciated.
Chris

-----Original Message-----
From: Michael St. Laurent [mailto:[email-masked]] 
Sent: November 14, 2002 3:00 PM
To: fwtk-users
Subject: [fwtk-users] Re: Smap documentation

-- 
Michael St. Laurent
Hartwell Corporation

> > documentation. They are:
> major contribution, besides a little debugging, was to comment the 
> heck out of the whole file.  Since that compilation, there have been 
> other patches; but I don't know which ones carried the comments along.
> 

---
You are currently subscribed to fwtk-users as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: Rick Murphy <[email-masked]>
Date: Mon, 18 Nov 2002 18:54:33 -0500

>I am running fwtk 2.1 and did find the documentation for a couple of the

Ok, but you still haven't explained where you got your copy of smap.
The fwtk 2.1 smap doesn't use a map file, nor a content file.
Is there some patch you've installed that added this? My suspicion is 
that you're using Ted Keller's patched smap, but I haven't seen it so 
can't be sure.
         -Rick

---

---

From: "Hutchison, Chris" <[email-masked]>
Date: Tue, 19 Nov 2002 07:28:31 -0500

I believe you are right about the smap patch.
I did download it back in January and have just recently tried to implement
it.
The readme does have Ted's name at the bottom.
Is there a more recent update of smap?

I would still like to understand how the map and content files work.

Chris

-----Original Message-----
From: Rick Murphy [mailto:[email-masked]] 
Sent: November 18, 2002 6:55 PM
To: fwtk-users
Subject: [fwtk-users] Re: Smap documentation

At 08:08 AM 11/18/02 -0500, Hutchison, Chris wrote:
>Thanks for your help!
>
>I am running fwtk 2.1 and did find the documentation for a couple of 
>the files.

Ok, but you still haven't explained where you got your copy of smap. The
fwtk 2.1 smap doesn't use a map file, nor a content file. Is there some
patch you've installed that added this? My suspicion is 
that you're using Ted Keller's patched smap, but I haven't seen it so 
can't be sure.
         -Rick

---

---

---

From: Rick Murphy <[email-masked]>
Date: Mon, 25 Nov 2002 23:12:57 -0500

At 08:16 PM 11/25/02 -0500, Hutchison, Chris wrote:
>re-scanning directory
>child 728 deliver sma004283 curpid=1 maxpid=50
>reap 728 exit=256 curpid=0 maxpid=50
>child 729 deliver sma000490 curpid=1 maxpid=50
>from <[email-masked]>
>from <[email-masked]>
>child 730 deliver sma000521 curpid=2 maxpid=50
>child 733 deliver sma012852 curpid=3 maxpid=50
>reap 733 exit=256 curpid=2 maxpid=50
>
>I would like to know what "reap" means as these messages are not being
>delivered.

That's the exit status from the child. 256 implies that the sendmail 
instance exited with a 1, not a 0.
What does the sendmail instance log when it tries to deliver a message?
         -Rick

---

---

From: "Hutchison, Chris" <[email-masked]>
Date: Mon, 25 Nov 2002 20:16:29 -0500

Ted,

I am interested in the latest code.  Please indicate where I can download
it.

I am also getting an error from smapd.
This is the message when run in debug mode.

Smtp4:/# /usr/local/fwtk/bin/smapd -d

re-scanning directory 

Thanks
Chris

-----Original Message-----
From: Ted Keller [mailto:[email-masked]] 
Sent: November 19, 2002 1:17 PM
To: Hutchison, Chris
Cc: fwtk-users
Subject: Re: [fwtk-users] Re: Smap documentation

I can make the lastest available for those who are interested.

tek

On Tue, 19 Nov 2002, Hutchison, Chris wrote:

> I did download it back in January and have just recently tried to 
> implement it. The readme does have Ted's name at the bottom.
> The fwtk 2.1 smap doesn't use a map file, nor a content file. Is there 
> some patch you've installed that added this? My suspicion is that 
> you're using Ted Keller's patched smap, but I haven't seen it so can't 
> be sure.
>          -Rick
>
>
> ---
> You are currently subscribed to fwtk-users as: 
> [email-masked] To unsubscribe send a blank email to 
> [email-masked]
>
> ---
> You are currently subscribed to fwtk-users as: [email-masked] To 
> unsubscribe send a blank email to 
> [email-masked]
>

---

---

From: Joseph S D Yao <[email-masked]>
Date: Tue, 26 Nov 2002 12:14:09 -0500

> This is the message when run in debug mode.
...
> I would like to know what "reap" means as these messages are not being

Do you have 'smapd' being called from a 'cron' job?

---

---

From: "Hutchison, Chris" <[email-masked]>
Date: Thu, 28 Nov 2002 11:30:57 -0500

Joe,

Smapd is started at boot as a daemon.  It appears to work just fine.
I found my problem for the "reap" message.
It looks like the old version of smap I had created a temporary xma??????
file and renamed it sma??????.
The new smap appears to load as sma?????? with 600 as the permissions and
then chmod to 700 once completed.
The email I was having problems with were still 600.  This probably had to
do with my testing.
I was playing around quite a bit to confirm the integrity of the new code.
Haven't had a problem since.

Thanks for your help!

-----Original Message-----
From: Joseph S D Yao [mailto:[email-masked]] 
Sent: November 26, 2002 12:14 PM
To: fwtk-users
Cc: fwtk-users
Subject: [fwtk-users] Re: Smap documentation

On Mon, Nov 25, 2002 at 08:16:29PM -0500, Hutchison, Chris wrote:
> Ted,
> 
> I am interested in the latest code.  Please indicate where I can 
> download it.
> 
...

---

---

---

From: "Hutchison, Chris" <[email-masked]>
Date: Thu, 28 Nov 2002 11:35:08 -0500

Ted,

Thanks for the new code.  Everything looks good.
Figured out my "reap" problem as per my email to Joseph Yao.
Still need some help with the map and content files for smap.
Any documentation or examples would be helpful.  Don't fully understand the
one's included with the code.

I am also trying to use the code for syslogd but can't seem to get it to
work under Solaris 2.7.
Each time I start the daemon it replaces the link "/dev/log ->
../devices/pseudo/log@0:log" with a file "/dev/log" and nothing logs.

Again thanks for your help!

Chris

-----Original Message-----
From: Ted Keller [mailto:[email-masked]] 
Sent: November 25, 2002 9:33 PM
To: fwtk-users
Cc: Hutchison, Chris
Subject: Re: [fwtk-users] Re: Smap documentation

Chris,

The "reap" messages refere to smapd collecting the spawned childern that
have completed their delivery process.  You should also see in the logs
"message delivered" for each of these as well.  If they are not being
delivered, check out your sendmail configuration.  Keep in mind - if you are
running things chrooted (not supported by standard smapd) you must also have
sendmail operational in chroot environment.  This is must a bit sloppy - due
to the numbers of devices/libraries/files that you have to put there.
Otherwise - run in unchrooted - and things will be a bit easier to
implement.

I will put the latest copy out on my ftp server - and forward you privately
the link.

ted keller

On Mon, 25 Nov 2002, Hutchison, Chris wrote:

> > implement it. The readme does have Ted's name at the bottom. Is 
> > there a more recent update of smap?
> >
> > >I am running fwtk 2.1 and did find the documentation for a couple 
> > >of the files.
> >
> > The fwtk 2.1 smap doesn't use a map file, nor a content file. Is 
> > there some patch you've installed that added this? My suspicion is 
> > that you're using Ted Keller's patched smap, but I haven't seen it 
> > so can't be sure.
> >          -Rick
> >
> >
> > ---

---